Error "Failed to open ALSA device" on Hifiberry Dac Plus (Amp 2), Volumio 2.799

After updating to the latest release, I got “failed to open ALSA device…”. I then re-downloaded the latest release, and started fresh with this one, but got the same error. Its appears that this DAC is no longer working.

Suggestion: It would be great if the Amp 2 would be in the list. As it is now, I have to select the “Dac Plus”, which seems to be compatible with the Amp 2. Is there a particular reason for the lack of the Amp 2 ?

Did you enable the I2S DAC?


Thanks for your reply. First, all I did was upgrading. After the reboot, it no longer worked. Then, I started fresh with a newly downloaded image. I did the usual setup, including the I2S enablement. It still does not work.

Found this thread and changed the /boot/cmdline.txt as suggested. It is working fine now.

First I was not successful, because I misread and changed /boot/config.txt

1 Like

Please see No sound out of HiFi Berry DAC + with Volumio2 (2.799)