Empty library - solutions, alternatives?

I have found this bug report which suggests that Volumio (or its underlying engine) has problems with handling libraries of over 10k.

I have a similar (the same?) problem. I added/mounted NAS using webui and it worked (green tick). Initially it was visible in the library and I could browse (and play) some of the music (it was still indexing, so only a few folders were visible), but now, after it has finished loading everything, I don’t even see NAS in the library folder in webui (only usb, radio etc.). Any suggestions? Has there been any progress made on the 10k files limit? (I am confident that my collection is way beyond that).

Do you know if minidlna has the same problem? Maybe I should switch from Volumio to minidlna and just stream from bubbleupnp? Are there any other alternatives for Rasp Pi+?

Thank you for help!

I have managed to get bubbleupnp to marry volumio upnp with windows media server. It works - not amazingly (library browsing is very slow, despite the server being top quality), but I guess that’s as good as it gets. I wish I could use volumio native controller, though…

I might consider running xmbc distro as renderer. Has anyone tried this solution? How does it compare to volumio? Any problems with large libraries?

i have a library with 35’000 songs … i had similar Problems -> look here. Perhaps it will help you …

Greetings Andi

Perfect, that’s precisely what I was looking for! Thank you for help and for describing it so clearly.

I guess it would be nice if Volumio added a custom option to the menu to setup the swap file (and its size and location), to make it easier in the future.