Empty directory listed in NAS

I finally managed to setup my NAS share (running on NAS4FREE, shared via SMB), I get that nice V sign next to the share listed. I had to manually create the directory /mnt/NAS/Music to get this working.
From SSH I can see the contents of my music folder on the NAS.
But MPD doesn’t list anything in the Volumio UI. The NAS directory is shown as empty.

What could be the issue?

I finally decided to give up on trying to get the NAS to list the files, and moved to a local USB storage.

Mostly all is working great, but I did notice stuttering on a particular album that is high bitrate (24/192), the audio would play for a second or two, then pause, then return, repeatedly. It doesn’t happen with other 24/192 files, just this album, I noticed the bitrate in MPod listing it as much higher than other files. I tried to tweak some settings in playback menu (buffer size, percentage), but it didn’t help.

If someone wants to give it a try please send me a PM and I’ll provide a link to one of the files (I don’t want to publish a copyrighted file on the forum). The album is Michael Jackson’s “Thriller”, by the way.

P.S. Anyone out there can recommend the best kernel configuration for a CMedia based DAC (Emotiva XDA-2)?


I have the same problem. I have eventually managed to mount my Music folder on the HDD (attached to my iMac). I can navigate to NAS - Drobo - Music, but can delve no further. Within the Music folder are a many folders for artists and within these for albums. Can anyone tell me how I can get to browse the music folders?

Update to 1.3 , a mate had the same problems after upgrade it worked instantly.


mount your NAS all with undercase (small letters!) even if they are different in your normal path.

I have 1.3.
I’m now connected by NFS and everything is fine.