Dongle Wi-Fi TP-LINK model n. TL-WN725N Ver. 2.0

I’m a new, enthusiastic user of Volumio with a problem: I bought a Wi-Fi device TP-LINK, the TL-WN725N Ver: 2.0 that is not recognized by Volumio.
Can anyone give me some help?

My name is Francesco, I live in Perugia, Italy.
Welcome and thank you in advance.

Welcome. I’m both fairly new to this forum and fairly inexperienced with Linux, but I’ll help if I can.

I’m not sure I understand the question. I’ve got a TP-LINK TL-WR1043ND. I can get to my RPi’s and to Volumio, using Putty or web browsing, and I can browse from the two Raspbian RPi’s. The wireless router has a USB port and I haven’t tried using it as a NAS. One of the Raspbian RPi’s hosts the NAS.

So could you please give more details with “not recognised”?


Realtek chipsets and Linux are a pain in the :unamused: ss

Got it working now with the TL-TL-WN725N Ver. 2.0

Maybe i should check out the specs and firmware (only windows on the manufacturer site) before i buy the most popular and cheap 1.

Well here is your sollution:

I stepped down to kernel 3.10.18 (54) , read the thread and it worx for me fine.

Ciao from Holland

Just got through the same process, installing volumio beta 1.2 on my Pi.

Not sure I understood the proposed solution (downgrading kernel?) but the following worked for me:

Checking Volumio build (uname -a) showed kernel build version 3.10.30+ #650

Going to this page and locating the drivers for the closest build (3.10.30+ #642), which happened 8188eu-20140214.tar.gz, and that you can download there:

So all in all:

tar -zxvf 8188eu-20140214.tar.gz
sudo install -p -m 644 8188eu.ko /lib/modules/3.10.30+/kernel/drivers/net/wireless
sudo cp 8188eu.ko /lib/modules/3.10.30+/kernel/drivers/net/wireless
sudo insmod /lib/modules/3.10.30+/kernel/drivers/net/wireless/8188eu.ko
sudo depmod -a

And you’re good to go!


“I stepped down to kernel 3.10.18 (54) , read the thread and it worx for me fine”

better words where i adjusted the kernel version :wink:

@ cauchy: the file is down…do you know a other dl or can you upload it?

try this…

thx for the link
its now working!

List of all drivers:
Which version is needed: