Does Volumio support HiFiBerry DAC+DSP?

Looking to setup a RPi 4 (4gb) & HiFi Berry DAC+ DSP combo. Does Volumio support this board?

yes I am using the combination, to use the DSP you need to install python 3.5 and pip3 before you install dsptoolkit.

rest you just follow the prompts on Volumio

found all the old links
edit config.txt

To install python 3.5 use this guide


bash <(curl
make sure there are no errors

Excellent! Thanks for the quick response and help! :grinning:

Hi Chris, just marked the post by ‘panch’ as solution … please delete if you don’t feel that it has answered your question.

I’ve had some issues trying it this way. After I tried fixing the issues I ended up reformatting the sd card and started over. Second time I had other show stopper issues. Third time reinstalling Volumio I checked and noticed it has Python 2.7.9 by default. Why can’t I just use the python version that’s already there with dsptools or update to a later python version (seems like 3.6x works best)?

yepp, dsptools needs 3.5 /3.6 ( but not 3.8) and Volumio is stuck on 2.7.9

hence the long process to upgrade Python first and then only installing dsptoolkit. And keeping fingers crossed.
As soon as I had a working system, i just created another image which is now my starting point in case I mess up again or upgrades go bad…

Thanks Panch.

The issue I am running into is after the seeming successful Python 3.6.5 install:

sudo pip3 install --upgrade hifiberrydsp returns an error once it reaches the step of installing the lxml package. It fails with error code 1:

send the output of
python -V
python3 -V

if you get error for python3 you might have to setup the path


i think you need to set the path options , and try to install dsptoolkit

try the curl script

Thanks, tried your suggestions, but upon running the curl script, at some point it returns:

let me find a spare card and try from scratch

That is much appreciated! :smile:

ok this is what I did

sudo apt-get install build-essential libc6-dev
sudo apt-get install libncurses5-dev libncursesw5-dev libreadline6-dev
sudo apt-get install libdb5.3-dev libgdbm-dev libsqlite3-dev libssl-dev
sudo apt-get install libbz2-dev libexpat1-dev liblzma-dev zlib1g-dev
cd $HOME
tar -zxvf Python-3.5.2.tgz
cd Python-3.5.2
sudo pip3 install -U pip
sudo pip3 install -U setuptools


bash <(curl


then setup volumio   (configure volumio like which dac, size of web art etc)

my mistake, setup means configure volumio like which dac, size of web art etc

Sadly, ran into more issues:

sudo apt-get install build-essential libc6-dev does not work until I do this:

apt-get update
apt-get install apt-file
apt-file update

Then all proceeds well until:

sudo pip3 install -U pip - Error is returned: sudo: pip3: command not found

Seems like the version of pip installed doesn’t support the version of python. So I did this to uninstall pip and reinstall the system pip:

sudo apt purge python-pip python3-pip
sudo rm -rf /usr/local/lib/python2.7/dist-packages/pip
sudo rm -rf /usr/local/lib/python3.4/dist-packages/pip
sudo apt install python-pip python3-pip

Now when I try to run:

sudo pip3 install -U pip

I get this error:

ImportError: No module named 'pip._internal’

RE: This error -
ImportError: No module named 'pip._internal’
When I do:
python -V i’m getting version 3.4.2 despite having installed 3.5.2 according to the instructions above. This prompted me to check the ~/.bashrc for an alias. None exists.

So why is python3 still referring to 3.4.2 if i’ve installed 3.5.2? The mystery deepens…

try a uninstall or

what I will suggest take another SD card install just volumio and see if python3.4 is installed, or follow the steps, and see who is doing it

Volumio by default has python 2.7.9 out of the box. When trying to install python 3.5.2, python 3.4.2 installs??!!! Not sure why. Those two (2.7.9 & 3.4.2) appear in usr/bin but 3.5.2 does not, despite my having compiled and installed 3.5.2.
I’m afraid that’s where my skill ends at Linux command line. I’m officially stumped for now.

Hi, I see you have Python 3.6.5 installed. I need python 3.6 so I install it but now I cant make it default
~ python -V
Python 2.7.9
~ python3 -V
Python 3.5.3

Python 3.6 is installed but cant make it default, tried adding an allias on bashrc but can make it work
~ which python3.6

Any advice about this?