Does not allow WiFi password entry - SOLVED

Hello All, I have installed Volumio 2.6 on a Raspberry PI 3b+ with Allo Boss DAC, then connected to my NAD amplifier, works perfectly when playing music from local HD but cannot configure it to connect to my WiFi Network.
Network name is shown among the ones to connect but when selecting it I don’t get the option to tape the password, I attach as it looks like.


I formatted already once the Micro SD but nothing has changed.
Has anybody had a similar problem? Is there anything wrong I’m doing…? Any suggestion highly appreciated… Thank you

Update 26/01/2020
Connected to Ethernet, I could access Network and field to enter password was there! For some reason it was dropping outside the LCD screen of my iPhone. Password entered and problem fixed

Any idea by anybody…?
The field to enter the WiFi password does not appear so I cannot type it / configure it.

I modified the picture to show it better…

I tried the same operation using my iPhone and a Raspberry PI 3 and Volumio of a friend of mine and everything works properly.
Then, back to my system, I changed language to English and the background colors with not any improvement.

Can the problem be connected to an issue with my Raspberry PI 3b+?

I’m new with this system, please some support if anybody has any idea… thank you!