DHCP failed with systemctl message

Ok so I re-flashed my volumio to 3.1 (the version before feb- 2022 release) and I had my wifi dongle working before on my Raspberry Pi, but now it’s not. I used the systemctl command and it said DHCPCD failed. What should I do to force DHCP to assign a new address? I released and re assigned all interfaces, and it made one just fine for ethernet, but for wireless Wlan0 it says waiting for carrier. Not sure how to fix this.

Guys? How is there no support? I spent all day finding out that the isc-dhcp-server package isn’t pre-included. Like what? no wonder volumio doesn’t work out of the box like it should. If I use apt-get update command then it is able to find the dhcp server package. But I read it will break the system if we do an update like that. If I don’t use the update then it won’t find the dhcp package at all. How do you fix this?

apt-get update will not break your system … but apt-get upgrade will.
if you want any help always say what version of volumio your using and all the other things needed to help.

best regards,
dvo

Give them some time. It makes no sense to push for answers 4 hours after your initial question.

Check the recent topics dealing with WIFI-Dongle issues with the new kernel. Think there is your problem…

DHCP is of course installed on Volumio, both client and server.

As already mentioned, your problem is due to the fact that with latest Volumio versions some Wi-Fi dongles are no longer supported (and that unfortunately won’t change).

I had another post open about 4 days ago.

I am actually using Volumio 3.179-2021-12-20 (or linux kernel 5.4) and this setup was working fine for me a few months ago. I had actually set up my wifi and everything before. So it looked like my driver wasn’t loading, but I am getting exit code 6 which means DHCP is not configured.

Ok, I am using Volumio 3.179-2021-12-20 (or linux kernel 5.4) the one released before the February 2022 update. Sorry if that’s not the version you need, but this was all I got during my troubleshooting. Also, I scoured the forums and saw no mention of current issues with dongles and the newest release.

I got really close to fixing it I think. I tried to force it to IPv4 with a static IP, and then I got a different connection error saying “wlan0: trying to associate with (my router’s MAC)” then later it says “auth_failures=3 duration=46 reason=CONN_FAILED” So I’m not sure if it’s a password issue, or an IP version issue, and I took down firewalls, and made the network open. Still nothing. Trying to buy the ASUS USB AC51 since that is reported to work, I noticed its the only recent ASUS dongle that has linux support too.

Ok so I figured out either my router or the app is not working right. When I disconnect Ethernet and try to connect directly to my dongle my device (Pi 2 B) will never show up in the app. But if I connect my Pi to my phones hotspot that is connected to my home wifi, then it works and my device shows in the app. I pinged 8.8.8.8 plenty of times. I’m not sure why I saw messages saying that DHCP wasn’t working and exit code=6 and all that, there’s a lot of things that were steering me in the wrong direction.

I also have no explanation as to how I had it working last December, because I connected directly to my wifi dongle at that time. I have a CCNA certificate so I can see in my router there are no MAC addresses being blocked, my Comcast tech also could not figure out why there is some kind of block. Or maybe it’s the app? IDK.

Did you try with the app only or also by typing the ip address?

The app is probably working right, I misunderstood the purpose of the software. I am trying to use it with my car. So just to be clear, you do need it to be connected to a network? Not necessarily with internet, but definitely a network? So if I’m away from home, I would need to use my phone’s hotspot to get it to work.

I read somewhere if you pay you can get better features, and there might be bluetooth support? My phone would die pretty quick with a hotspot on, so any more options to control the app would be great.
I tried using the app and manually entering the IP. I guess the beginners guide confused me too, because Volumio should make it’s own (fallback) hotspot for the phone to use? I tried doing something like that, but it doesn’t work.