Device does not show up in MyVolumio dashboard

Hi,

I just installed the MyVolumio image, subscribed to MyVolumio using G+ login and upgraded my account to the paid subscription Virtuoso.
If I read the manual correctly my Volumio device should show up in the MyVolumio dashboard automatically. However, it does not.

Not sure how to debug this further. I can access the volumio via volumio.local and everything works, except MyVolumio. Any suggestions?

Niels

tempsnip.png

I am one step further. I ssh-ed into the pi and scrolled through the /var/log/volumio.log file for a while, didn’t see anything strange there.
After reloading a couple of times I noticed a MyVolumio login window in the volumio.local website. I am sure this wasn’t there first.

I looks like I can’t login with G+ credentials that is linked to my subscription. It seems to me I can only login using the volumio credentials (which I don’t have). Am I correct assuming this is not implemented yet and I was too early subscribing with G+?

thanks,
Niels

PS The reason I subscribed with G+ was because I couldn’t subscribe with a MyVolumio account due to a “your password does not match the format” error that was reported earlier.

Capture.PNG

You should have set up a password to be able to use MyVolumio, was it the case?
If not, login and then reset your password to find out which one you have.

With this you should be able to login from local ui. Let me know

thanks for your quick reply.

I did not have to setup a new password during the signup process. By clicking the G+ logo I had to select my google account (I have two associated with my google chrome), and was signed up without setting up a password. It uses the one I am already logged in with in my browser.

signup.PNG

Also logging into MyVolumio I just click on the G+ logo and don’t enter a password since I am already logged into Google with my browser. The login should receive a valid token from Google.

I expect on the volumio.local website the same procedure where I can click on such a G+ logo to login without entering a password on the volumio.local website itself, since it receives the Google token.

As you suggested I changed the password in the MyVolumio profile. And now I can login. Thanks!
Maybe my google password contains illegal characters according to your desired format. It works now, but I think it doesn’t completely follow the standard federated authentication routine, at least not in volumio.local.

Anyway, works for me now so I’m happy.
Thanks for your great work on Volumio!

changepassword.png

Thanks, very useful feedback.
We need to ask explicitly upon first activation to users to set up a password for their account.
For security reasons, we cannot use Google\Facebook\Github login on local ui (just on MyVolumio.org)

Thanks for the feedback!

I’m glad the feedback was useful!

I don’t think it would make much sense to subscribe with a Google/Facebook/github account if you need to change the password anyway. After changing the password I can’t use the Google login button anymore (it redirects back to the login page), but I have to login with my new password (and the e-mail address associated with the Google/Facebook/Github account). So it only works while subscribing.

Maybe just remove it until it works correctly. I think MyVolumio users are the type of people with enough enthusiasm about your product that they are willing to spend the time to subscribe with a separate account.

Very interesting feedback, thanks again.

am unable to enable my dvice in volumio