Dac problem

Ok, I’ve a Dac USB (Teac UD-H01) and with Raspyfi it was OK.
Now I’ve a lot of problems: Volumio starts only when the Dac is off, and when the Dac is on I can’t see Volumio. In other words, Volumio and my Dac are not compatibles.
What can I do?

There is a new kernel on Volumio which seems to be a little choosy about what to do with USB Dacs.
Just connect the DAC before turning the Pi on, and connect via ssh and type (user root, password volumio)

aplay -l

Please paste here the result.

I don’t know if you have noticed, but from settings menu, go to playback, there’s a output selection menu, see if changing something may help (try also to set mixer as disabled).

I’m sorry, but when DAC is on it’s impossible to see Volumio (also with SSH). It seems like Volumio doesn’t like my DAC Teac! It’s weird becaus with Raspyfi everything was OK

Ok, maybe I find the way to see my DAC. There is a problem with the reboot command. All the time I tried rebooting my Raspy and in this case I couldn’t see my DAC. At the end I powered off the machine (instead of rebooting) and (magic!!) everything it’s ok.
I think there is a problem with this command (I mean “reboot”).

Yep, the new kernel has this bug. For the rest, is everything ok?

Not really :blush:
Today Volumio doesn’t want see my Dac. I can only reach Volumio (by SSH or Web) when Dac is off.

Even aplay -l shows nothing?

Try to change USB port, if this works this is a big clue for me…

Nothing! It’s impossible to connect to Raspy when Dac is on! On the contrary, when I switch on Raspy before Dac there is no problem to log in Volumio, but the Dac isn’t in the audio output (in Volumio I see only “Alsa” and “Nothing selected”), and obviously I can’t hear anything.
With aplay -l this is the log:

Ps: I changed USB on raspy but the result is the same

That is weird… Do you know which USB receiver your DAC uses?

Ma Teac Ud-H01 has a USB Audio Class2 High-speed Input from PC/MAC (Tenor 8802) and supports asynchronous transfer mode


My MUSE DAC using a CM108AH USB receiver is not working and didn’t work with RaspyFi either. I followed the advice above and listed the audio devices with aplay -l and it just shows the ALSA one on board. My DAC shoes power the connection light (in blue) does not come on. I have also tried both USB ports and tried rebooting the system with the DAC attached. Any help would be great - I am already enjoying it just through the on board audio!


Okay, fixed it. It was a power issue. The DAC comes with a power plug as an option when it’s used as a straight optical/SPDIF DAC. I have used it on my laptop just powered from the USB port and it worked. I guess the Pi was just not able to power it!

Thank you for developing this software, it’s great!


Samar reported its DAC to work properly here:


sorry but I don’t understand. The link you show me doesn’t talk about my DAC (Teac ud-h01). Until now for me it’s impossible to turn on Volumio with the Dac on (I can’t see Volumio, neither on web interface nor by SSH!).
It’s weird because with Raspyfi there isn’t any problem.

Great!!! :stuck_out_tongue: :stuck_out_tongue:
With the new release everything it’s OK! Now Volumio see Teac DAC and I can use the Web UI!
There is only a minor bug: I can’t use Volumio with a static IP. When I tried there wasn’t connection with PI, but I must do other essays to be sure about the bug.

Hi I have a similar problem using the HiFimeDIY Sabre U2 Asynchronous USB DAC, which worked perfectly under RaspyFi. When I run dmesg, I can see that the DAC was enumerated, but [aplay - l ] shows nothing except the built in Broadcom device.

For the moment, I’ve rolled back to RaspyFi (which is working very nicely), I’ll try Volumio later as it moves out of beta.


This could be a power issue… Please try to change your power supply (example: a smartphone charger)

Let me know!

Hi John,
did you succeed with volumio and your DAC? I really have the same issue on the latest release.

Update 25 July 2014: the problem described below has been solved by using the 3.10 kernel referred to in this thread: wifi-cubox-t1117.html

Its working great now with the TE8802L based Yulong U18 (yulongaudio.com/en/product_detail.asp?pid=23) (using its regulated power supply).

After tweaking /etc/mpd.conf to:
samplerate_converter “Best Sinc Interpolator”
its sounding shockingly good. That change (from “Fastest”) seemed to remove some top end harshness and improve dynamics. The cpu usage of mpd is not even exceeding 1% on the Cubox i4 Pro. Sweet!

--------- original problem description:
Sorry to revive an old thread but I too have a TE8802L based async USB audio interface device which, like the OP’s TEAC DAC, does not work with Volumio (latest version I believe, using kernel 3.0.35 armv71) on cubox i4 pro.

I know this device works on Linux as I’ve had it working on a Squeezebox Touch with EDO. And, as was reported as far back as April 2012:

“Support has been added for the TE8802 (specifically for Teac UD-H01 DAC but should work for all) in linux kernel 3.2.21. Ubuntu i12.0.4 isn’t there yet (3.2.0).” ( Reference: head-fi.org/t/609062/te8802- … the-sbt/15 ).

Does that not mean that this later kernel should support TE8802L devices like the Teac, the Yulong U18 (mine) and some Audio-GD devices as well?

My Linux kernel building skills are not too flash. I’m wondering what might be involved with bringing this more up to date kernel to Volumio on its Cubox-i distro, or if there are any plans to upgrade the Volumio 3.0.35 kernel to something at or above the 3.2.21 kernel which should support TE8802L?

Any guidance would be appreciated. What is easiest – redoing a distro for the cubox-i with latest possible kernel and then trying to install volumio on top of that, or just trying to upgrade the volumio kernel? If the latter, any pointers most welcome.


I also have Teac UD-H01 and it seems there is a major problem when playing HD 96-24 flacs via USB (heavy noise and crackling). Surfing the net one may find this patch: spinics.net/lists/kernel/msg1761225.html
but I am not able to find the kernel files mentioned there…anybody can help? I need the complete path of the files.
Thanks in advance.