Custom mount point in /mnt not working

I’m trying to mound a folder in /mnt/remote using rclone (rclone.org) and it’s mount feature.
The actual mounting process works, and I can access the the files in ssh, but they don’t show up when scanning for new files.
I have made a systemd service script for startup with user volumio.I also use the user volumio when logging in via ssh.

When I start a new scan, Music Library–>INTERNAL shows up, but is empty
Also tried symlinking to /var/lib/mpd/music without success

It should work with the symlink but just check your permissions … also the link should be to your custom mount point

eg.

mkdir /mnt/test ln -s /mnt/test /var/lib/mpd/music/test

This is not working for me.
I even tried your example, and put a couple of mp3’s in the test folder

Here are the permissions for the mount folder (it’s mounted as read-only)

rwxr-xr-x 1 root root    0 Feb 15 16:51 remote

There’s something not right with ‘remote’ …it doesn’t look like a directory.

I’m pretty sure it is…
I have no problem cd’ing into it from shell

Here’s the systemd service that I use :

[code]
[Unit]
Description=rclonemount
After=network-online.service

[Service]
Type=simple
ExecStartPre=/bin/mkdir -p /mnt/remote
ExecStart=/usr/bin/rclone mount ds:/music /mnt/remote --config /home/volumio/.config/rclone/rclone.conf --buffer-size 100M --dir-cache-time 30m --max-read-ahead 200M --quiet --read-only --allow-other
ExecStop=/usr/bin/fusermount -u /mnt/remote
Restart=on-abort

[Install]
WantedBy=multi-user.target[/code]

Might be useful to narrow down the problem by separating out the rclone stuff from the actual symlinking a directory for Volumio/mpd search to find files ie. make a directory by hand, symlink it, add some music files and see if they turn up in the library??

My /mnt directory contents:

[code]drwxrwxrwx 1 root root 1024 Feb 16 10:30 .
drwxrwxrwx 1 root root 1024 Jan 1 2011 …
lrwxrwxrwx 1 root root 14 Dec 22 22:52 INTERNAL -> /data/INTERNAL
drwxrwxrwx 1 root root 1024 Nov 22 10:19 NAS
drwxrwxrwx 2 root root 3 Dec 22 22:52 UPNP
lrwxrwxrwx 1 root root 6 Dec 22 22:52 USB -> /media
drwxr-xr-x 2 root root 1024 Feb 16 08:56 test

[/code]

Folder should be owned by volumio group and user, so mpd can read from it.

Contents of the folder should be volumio owned … no??

Strange, but it actually works now…
I started a rescan yesterday, and now the remote folder is there.
Maybe the scanning is slower with fuse?

I am having the same issue can you tell me how you did this? My folder is also empty