Cubox-i4-Pro USB DAC not recognized

Hi , I have a TEAC UD-501 DAC and would like to use it with Volumino 2 on Cubox-i4-Pro.

I installed from latest dev version since otherwise library scanning (NAS) was not working.

When connecting the TEAC DAC the log looks OK:

Apr 16 20:05:34 volumio kernel: usb 1-1: new high-speed USB device number 3 using ci_hdrc
Apr 16 20:05:34 volumio kernel: usb 1-1: New USB device found, idVendor=0644, idProduct=8043
Apr 16 20:05:34 volumio kernel: usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Apr 16 20:05:34 volumio kernel: usb 1-1: Product: TEAC UD-501
Apr 16 20:05:34 volumio kernel: usb 1-1: Manufacturer: TEAC Corporation
Apr 16 20:05:35 volumio kernel: hid-generic 0003:0644:8043.0001: hiddev0,hidraw0: USB HID v1.10 Device [TEAC Corporation TEAC UD-501] on usb-ci_hdrc.0-1/input2

But unfortunatly USB doesn’t appear in the playbck options.

doing aplay -l it doens^t appear also not int the Paylback Hardware devise

**** List of PLAYBACK Hardware Devices ****
card 0: SPDIF [Integrated SPDIF], device 0: S/PDIF PCM snd-soc-dummy-dai-0 []
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: imxhdmisoc [imx-hdmi-soc], device 0: i.MX HDMI Audio Tx hdmi-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

only SPDIF (works over optical TOS-Link) and HDMI-Audio

anybody got Volumio successfully connected to an USB-DAC and knows what to do?

Since I listen often to High-Resolution Audio I would like to use USB instead of TOSLink. I tried also the HiFace Two DAC but same result.


TEAC, as a usb 1.1 device, is obviously not recognized by the kernel, there is not much we can do.
I’ve tested usb audio devices, they were all class 2 (usb audio 2.0) and worked.
With a few usb 1.0 exceptions on C1/C2 for which we could do usb drivers changes supported by hardkernel.
Unfortunately I do not see that happening for cubox, as here we need to take what we get…

thanks to make that clear.