CuBox-i4-Pro: No music, etc.

Hi everyone,

I just bought a CuBox-i4-Pro and installed the newest Volumio version.
Out of the box I have the following problems:

  • No sound
    There isnt even coming any light from the optical S/PDIF.
    Audio output is set to imxspdif
    Volumio pretends it´s playing sound, with seconds ticking away, etc.

  • Volumio forgets the content of the media library after reboot
    Library is on NAS, access via SMB.
    I could not get NFS to work.
    I have to manually start a re-index upon restart, to see any songs.

  • Thumbdrives are not recognised
    Both FAT32 and NTFS

  • Library often becomes unresponsive and just shows the spinning arrows.
    Stays this way until I reboot the box.
    Also playlist gets deleted for no reason.
    My library has 16000 tracks

  • web interface is very slow.
    I tried Firefox, Chrome, Opera and the Browser on my Android tablet

I have not tried other distros, etc.

Is my cubox defective?
Should I send it back?
Or are these known problems with Volumio (ideally fixable ones)?


Just installed geexbox, and it seems to work (I can play music over S/PDIF).
So I guess my hardware is okay.

Are you sure you downloaded volumio for the cubox-i not the one for the older cubox? The image you should be loading is Volumio1.4Cubox-i.IMG.

Not sure if Michelangelo has updated it to include the drivers for WiFi but pretty much everything else works on the cubox-i 4 pro with no need for modding. WiFi issue is solved here

Hi oreja,

Don’t worry. I don’t think your cubox is defective.
I have myself a Cubox-i4 Pro and i can confirm that the path to get Volumio working on it is not as straightforward as with the Raspberry Pi (i have one also).

This a know issue. Michelangelo has worked on a new kernel that solve both wifi and S/PDIF.
Have a look at this post to know how to install it :
I can confirm that on my install with this new kernel sound over S/PDIF is working (with this known limitation due to the Cubox :

I’m using myself NFS. But i know that SMB is problematical. Have a look at this post : Maybe you will find a solution to your problem.

I have read other persons on the forum reporting the same issue. Use the search engine. You may find somebody who found a temporary solution until Michelangelo improve Volumio.

The library tab unresponsive is a know issue : Michelangelo is working on improving this functionality or allowing to disable it.
For your Playlist getting deleted, have a look at this post :

Don’t forget that Volumio is still in an early stage. Michelangelo keeps on improving it release after release. This is thanks to bug reports like yours that Volumio will improve. But you may have to be a bit patient.

Hope this helps.