Cubox i Update Issues


I have been running Volumio on two Cubox i boxes since April 2014, and was running on the Cubox Beta software for all that time! I play music using iTunes from an iMac - Volumio was always rock-solid when playing music stored locally on the iMac. However, when streaming radio stations, many times the system would hang within a few minutes and require a reboot of the Cubox before starting the stream again. This problem got worse and worse until recently I stopped listening to radio because it was so much hassle. :cry:

Last week I noticed that things have moved on (a LOT!) since 2014 :blush: so I updated my two Cubox units by flashing them with the latest download (2.129). I then happened to ‘Check Updates’ (even though I had just downloaded the latest disk image) and one Cubox updated to 2.239, but the other one is still on 2.129 and tells me that “No Updates Available. You’re already on the latest version”. The other box no longer responds to the ‘Check Update’ button, and I note that an even newer version (2.246) is showing in the Changelog.

So, in summary:
Box 1: Running 2.239 and will not respond to ‘Check Updates’ at all. I can’t ssh into this box at all, not even using sudo
Box 2: Running 2.129 and will respond to ‘Check Updates’, but will tell me (incorrectly) that “No Updates Available. You’re already on the latest version”. I have Deleted User Data, restarted several times and, beacuse I can ssh into this box, tried the sudo ldconfig -v trick that several people reported to have worked for them.

Any help that you can offer to make the boxes update to the latest version and behave the same way would be very much appreciated!

The issue appears to have been that the box that would not update was not in ‘TEST MODE’ - see here: … dates.html

I don’t recall setting either box to TEST MODE, but that appears to have fixed it, so I must have done… :blush: I’m still not sure why pressing ‘Check Updates’ does nothing at all at the moment, but at least it’s consistent across both boxes…