Credits info with Superstar

Volumio Information

Volumio Version:2.806
Hardware: pi4
DAC: HiFiBerry DAC+ Pro

Just upgraded to Superstar and I’m having trouble finding the credits info. I’ve watched the demo video but have not been able to replicate the action it shows.

Suggestions please.

Hi, I suggest to update to latest version.
Also, credits might not be shown on some less known albums

I do not see the green “Read More” link that you click in the video to show more info. It’s just not there.
For testing, I tried to get info for mainstream albums - Adele “21” for example.

Following your advice to upgrade to the latest system has led to more issues.
I did an over the air update to one of my Pi3 systems. It is now at 2.834.
Unfortunately it no longer sees the music library on the NAS. The path still shows up as mounted under Network Drives in Sources. The My Music section shows zero contents. Prior to the update it showed 4043 tracks.
I am able to play tracks from the NAS on my other Pi3 system which I did not update.

Looks like the issue came with the update. I’ve tried a restart and rescan of the library. No improvement.


On the updated system, do you have plugins installed?
Did you install stuff manually?
You can do a factory reset on this PI and it will for sure work again

The only plugins were there before the update. Nothing installed manually.
The only plugin is Volumio parametric eq, which was working fine before the update.

I’ll try the factory reset.

Thanks, please let us know

Ran the factory reset and the system restarted in Hotspot mode. It took me a while to figure out that was the situation. I’ve gone through the initial setup and it’s on wifi, but it did give me an error when I input the path for the NAS. I’ll have to look into that later. I usedthe same IP and path as on the other pi3 system where it’s working.

I’ve deleted the shared drive that was set up after the factory reset and re-entered the info in Settings. Looks like it worked. It’s scanning the library now.

Great, let us know

two steps forward, one step back. Everything looks good with the restart. Can play tracks from the NAS. Can see the credits info.

When it restarted the volume was stuck at 100%. Didn’t matter what I did with the slider control on the mobile. In an effort to get it under control I switched mixer to software (I’ve always used hardware). Now I can control it but I’d like to get it back to hardware and that option no longer shows up. Only choices are software & none.

For reference, the other p3 system is identical except for Volumio version. I have parametric eq on both. no other plugins. the 2.806 system is using hardware for mixer.

How can I get back to that option on 2.834 system?

negative developments. Now when I try to play anything- track or radio I get an error msg that “softvolume” does not exist.

I’ll redo the factory reset and see what I can get going. I’m questioning whether it is worthwhile updating the two remaining (functioning) systems to 2.834.

What DAC are you using?

HifiBerry Amp2. Described by the maker as equivalent to their DAC+ with integrated amp.

What did you select as I2S DAC?

HiFiBerry DAC+

Going on the 3rd factory reset. Different results every time. Maybe “third times a charm”.

here’s the current situation.
I have not been able to get an install of 2.834 working in regards to these features.

  1. functioning volume control
  2. Superstar features - credits, loopback ( I don’t currently need loopback but I did see it at one point)
  3. access to all tracks on NAS

I’ve had some combination of those features at various times in this (mis)adventure but never all of them at once.

I’ll get the 2.834 install from github and try that.

I’m assuming this isn’t typical and would love to hear what might be causing it so I can prevent it in the future. If I can get this working I have two more systems to update.

Update 10/8/2020:
Did a clean install on a reformatted the SD card with a downloaded 2.834. Seems to be working so far.
I can control volume, see and play tracks on the NAS and credits are available.
Not sure what happened with loopback. At one point among these resets loopback appeared then on the next reset it was gone.
I’m suspect that all features are functioning normally, but for now the critical thing is I can listen.

Will add the parametric EQ next and hope for the best.

I appreciate the attention to my original post.
Given the time difference I don’t expect real time support, but something more helpful than “reset and let us know” would have been nice.

Maybe its my WIFI, but I’ve concluded that over the air updates and factory resets introduce more problems than they solve. In future I’ll just do it the old fashioned way.

Ok now I understand a little bit better: you installed the EQ plugin, which messed up the configuration.
I suggest you to not install this plugin as it is now a bit “flaky”.
Things will improve soon, as we are working on a new way to handle EQ (and other) plugins.

That may be true but doesn’t account for any of what I saw in this. The difficulties began with the update, not with the EQ. The resets made matters worse, without the EQ being in the system.

If each reset had been functional before tuntil EQ was installed I’d have more confidence in this explanation, but that never happened.

FWIW after the clean install to 2.834 I have installed the EQ and it is working.

I’ll hold off on updating my other systems for now.