Controls missing from web UI

I have 2 volumio systems, one on a mini-PC and the other on an RPi. Both of them sometimes lose the bottom display on the web UI so there is no way to pause. Sometimes refreshing the page brings the controls back, but most times, refresh only refreshes the rest of the page, leaving the bottom blank. Is there some way that I can fix this? Thanks!

Can you explain more your setup? which PC? Which version?
Also please can you send logs when this happens?

I am currently working on an RPi setup, so I will describe that setup. The RPi is a new RPi 4, 64-bit with 8 GB of RAM. I flashed the latest volumio2 image on a 64 GB micro-SD card. When I first installed volumio, the web UI was fine. After some use, the background disappeared, as did the controls and other info at the bottom. My main PC is a Ryzen-based DIY workstation. I tried the web UI a few minutes ago on a Dell laptop with the same results: background and bottom info/controls missing. I sent logs after seeing the issue this morning and before checking on the laptop. My other setup is on an Intel-based mini-PC. On the mini-PC, the background and controls/info came back. Another hint might be that when the web UI has this problem, the Settings/Appearance display is messed up, with images overlapping.

Thanks Jack,

  1. Can you paste the log link here? This is the way we can look at them
  2. What power supply are you using on the PI?
  3. Which language are you using?

It still says that it’s sending the log, so I have no link as yet. I enabled live log, and below is what I had before and after I selected Music Library in the web UI. I am using the Cana power supply that came with the RPi. I am using English.

Starting Live Log… info: CorePlayQueue::getTrack 0 info: CoreCommandRouter::executeOnPlugin: appearance , getUiSettings info: CoreCommandRouter::executeOnPlugin: wizard , getShowWizard info: CoreCommandRouter::executeOnPlugin: system , getShowWizard info: CoreCommandRouter::executeOnPlugin: system , getPrivacySettings info: CoreCommandRouter::executeOnPlugin: appearance , getBackgrounds info: CoreCommandRouter::executeOnPlugin: my_volumio , getMyVolumioStatus info: CALLMETHOD: system_controller system enableLiveLog true info: CoreCommandRouter::executeOnPlugin: system , enableLiveLog info: Launching a new LiveLog session info: CoreCommandRouter::executeOnPlugin: mpd , handleBrowseUri info: CURURI: music-library info: CoreCommandRouter::volumioGetQueue info: CoreStateMachine::getQueue info: CorePlayQueue::getQueue info: Listing playlists

Refresh the dev page and just click send log, then paste the link here.

I assume you are connected with ethernet, right?

That time it worked. The log link is

From what I see your SD seems corrupted.

  • I see you have lot of devices attached. This can drain lot of power from the PI, lowering voltage and damaging SD


  • Use a powred USB hub to connect your peripherals (DAC, keyboard, HDD) etc
  • Make sure you feed the PI with a good 5V 3A power supply
  • Reflash the SD Card and try the 2 things above

let me know!

I wish that were the problem, but as I said, I saw the same behavior in the mini-PC setup. The mini-PC is an Awow computer: quad-code 1.5 GHz, 4 GB of RAM, 2 internal SSDs. It has no SD card. It uses USB thumb drives. Also, on the RPi, the power supply is 3.5A and I am using a powered USB hub for the mouse and keyboard with no HDD. The music is on a thumb drive.
I will try what you suggest with the SD card, but please look further for the problem, since a USB issue did not cause the identical problem on both the RPi and the Awow mini-PC.

I’ve run out of ideas then…

Which browser are you using?
Are you able to open the inspector of the browser and check the console for errors?

I have tried it on Firefox and on Chromium.

Are you able to check on the console what I suggested?
Also one question: did you install other stuff manually other than vim?
Did you do apt-get upgrade?
Why is your ethernet eth1 and not eth0 ?

I was about to re-flash the card. I will put it back in the RPi for now to check things. In order to install vim, it was necessary to apt-get update, apt-get install apt-file. I did not do an apt-get upgrade. I don’t know why the Rj45 port is eth1. For a while, I had a USB to ethernet adapter, and that was assigned eth0 for some reason.
Just now, the background and controls reappeared on the web ui. The log files are

This is the same behavior I have seen on the Awow mini-PC. The web UI background and control go away with no apparent reason, and reappear with no apparent reason.