Control volumio with API problem

Hello Volumio community,

I’m really excited about your project and I’m running two volumios on RPI right now.
Now I have a problem and I need your help.
i would like to control my volumios via my iobroker and have tried a few commands.
Following problem now with both.
For example, if I send a “pause” (XXX.XXX.XXX.52/api/v1/commands/?cmd=pause) command, the music pauses too. If I send a “play” command after it, the playback starts again. If I try the whole thing a second time it does not work anymore. Also on the WEB UI the “Pause” “Play” button does not work anymore. I have noticed the same when I want to use the Volumio Adapter in iobroker. The same with the MPD adapter. Commands only work once.
I only have one reboot left to use the Volumio again.

I hope I could describe my problem sufficiently.
Thanks a lot

Which service are you trying to play?


it´s simply web radio. But it also happen with spotify or NAS streaming.
I tried to attach a video here, but it isn´t working.

I would like to show you what it is doing. After a control with a command it just say “start playing” on the right upper corner when i press the play button. it never stop´s or pause after that

1 Like

This is was i mean.
After a control via html or iobroker command, it is not possible to control via WEB UI anymore
Volumio play pause stop.jpg

I can confirm that issue still exist as @fuso described it earlier.
Whats more it influence on justboom IR remote too when trying to play again doesn’t resume play.
What can be different is that resuming from the button in BUI works all right. I will try to get out the command send to volumio on play and use it in API call.
Anyway this could be fixed as the one of the most important funtionalites. Thanks!

Very hard to understand what is wrong without logs.
Please trigger the error then send the log

Please send a log and paste the link here:

Hi Volumio,
thanks to find this trouble interesting.
Here are my logs:
I checked behaviour of volumio on two cases: internet radio,and spotify connect and pause/play and toggle scenarios.

  1. API request when playing from spotify connect with play/pause:
    http://volumio.local/api/v1/commands/?cmd=pause - OK
    http://volumio.local/api/v1/commands/?cmd=play - NOT OK (the music on BUI seems to be playing but it is not - it is still paused in spotify)
  2. Playing webradio with play/pause:
    http://volumio.local/api/v1/commands/?cmd=pause - NOT OK music is not paused but it seems like this in BUI.
  3. API request when playing from spotify connect with toggle:
    http://volumio.local/api/v1/commands/?cmd=toggle (on stop/pause)- OK - music stops and BUI shows it
    http://volumio.local/api/v1/commands/?cmd=toggle (on resume/play) NOT OK it is not starting but pressing play button in BUI resumes playback
  4. API request when playing from internetradio with toggle:
    works perfectly fine both in pause/stop and resuming playback.

looking forward to hearing from you!

For Radio, there is an inconsistency as we can’t pause a radio, just stop it. we will fix in the api.
For spotify connect I would say that the plugin dev shall take care of it