Connection refused to Volumio ( on RasPi) after updating to

Dear All,

possibly I made a bit too quick update from 0.957 (?) to 0.979 . . . . after that connecting to the device ends up with "connetion refused " I also tried to connect to port 3000 . . . at least that opens the Web interface but it is not usable at all - greyed out and the spinner in the middle of the screen enjoys itself . . .

Any idea?

cheers
T

You may encounter a problem when upgrading from this version. The easiest way is to download and reflash the last version… Sorry but it still a dev version

This seems an issue we’re getting quite frequently lately. We’re investigating why it happens.
One question: are you connected via wi-fi or ethernet?

Hi,
it is an ethernet connection. I also reflashed from scratch . . . same issue

cheers
T

in case it might help . . .

when I use HTML console in Chrome I get

vendor-3e6f291a59.js:196 GET 127.0.0.1:3000/socket.io/?EIO=3& … &t=LRWOy2z net::ERR_CONNECTION_REFUSEDo.create @ vendor-3e6f291a59.js:196o @ vendor-3e6f291a59.js:196i.request @ vendor-3e6f291a59.js:196i.doPoll @ vendor-3e6f291a59.js:196r.poll @ vendor-3e6f291a59.js:196r.doOpen @ vendor-3e6f291a59.js:196r.open @ vendor-3e6f291a59.js:196r.open @ vendor-3e6f291a59.js:196r @ vendor-3e6f291a59.js:195r @ vendor-3e6f291a59.js:195r.open.r.connect @ vendor-3e6f291a59.js:215(anonymous function) @ vendor-3e6f291a59.js:215
vendor-3e6f291a59.js:196 GET 127.0.0.1:3000/socket.io/?EIO=3& … &t=LRWOzmL net::ERR_CONNECTION_REFUSEDo.create @ vendor-3e6f291a59.js:196o @ vendor-3e6f291a59.js:196i.request @ vendor-3e6f291a59.js:196i.doPoll @ vendor-3e6f291a59.js:196r.poll @ vendor-3e6f291a59.js:196r.doOpen @ vendor-3e6f291a59.js:196r.open @ vendor-3e6f291a59.js:196r.open @ vendor-3e6f291a59.js:196r @ vendor-3e6f291a59.js:195r @ vendor-3e6f291a59.js:195r.open.r.connect @ vendor-3e6f291a59.js:215(anonymous function) @ vendor-3e6f291a59.js:215

does this mean anything to you guys . . . it is the npm-debug.log
[list]
GNU nano 2.2.6 File: npm-debug.log

0 info it worked if it ends with ok
1 verbose cli [ ‘/bin/node’, ‘/usr/local/bin/npm’, ‘start’ ]
2 info using npm@3.10.3
3 info using node@v6.3.0
4 verbose run-script [ ‘prestart’, ‘start’, ‘poststart’ ]
5 info lifecycle Volumio2@2.0.0-alpha4~prestart: Volumio2@2.0.0-alpha4
6 silly lifecycle Volumio2@2.0.0-alpha4~prestart: no script for prestart, continuing
7 info lifecycle Volumio2@2.0.0-alpha4~start: Volumio2@2.0.0-alpha4
8 verbose lifecycle Volumio2@2.0.0-alpha4~start: unsafe-perm in lifecycle true
9 verbose lifecycle Volumio2@2.0.0-alpha4~start: PATH: /lib/node_modules/npm/bin/node-gyp-bin:/volumio/node_modules/.bin:/bin:/usr/local/sbin:/usr/l$
10 verbose lifecycle Volumio2@2.0.0-alpha4~start: CWD: /volumio
11 silly lifecycle Volumio2@2.0.0-alpha4~start: Args: [ ‘-c’, ‘nodejs ./index.js’ ]
12 info lifecycle Volumio2@2.0.0-alpha4~start: Failed to exec start script
13 verbose stack Error: Volumio2@2.0.0-alpha4 start: nodejs ./index.js
13 verbose stack spawn ENOENT
13 verbose stack at ChildProcess. (/lib/node_modules/npm/lib/utils/spawn.js:33:16)
13 verbose stack at emitTwo (events.js:106:13)
13 verbose stack at ChildProcess.emit (events.js:191:7)
13 verbose stack at maybeClose (internal/child_process.js:852:16)

Hi,

I found a possible workaround

in change the file /volumio/http/www/app$local-config.json to look like

{"localhost": "http://192.168.0.xxx:3000"}

reboot and it seems to work ( at least I got the WebUI and could start some settings, the library is still scanning )

Does it make sense to you guys ?

Yes it does, it seems that the port forwarding from 3000 to 80 does not work, which version are we talking about? For which device?