connecting to ReadyNAS 1100 mounts

Hi there,

I’m trying to connect my Raspberry Pi 3 running Volumio 2.031 to my ReadyNAS 1100.
When I use Add New Drive In My Music/Network Drives, the ReadyNAS is shown.
I then fill in the correct settings for Alias, NAS IP Address and path and go to advanced options.
There I fill in the user (admin) and the password of the Readynas.
Volumio then quickly shows two green boxes saying it’s connected successfully to the ReadyNAS, but in Network Drives the share doesn’t appear.
When I go to Browse, My Library the NAS appears. Clicking on NAS shows me all attempts I’ve made so far (8) to connect to the ReadyNAS with different aliases and names but all of them show an empty screen when I select them.
I’ve tried mounting the NAS on both CIFS and NFS, I’ve also tried to use all kinds of settings in the options field but nothing seems to work.

What am I doing wrong?

Strange detail: It was working for one session on Volumio 2.011 but when I restarted the Pi it never worked again.

Gr, Tj