Connecting Synology NAS via NFS to Volumio

I have previously used Volumio and then moved over to RuneAudio, now I am back and have struggled to get Volumio to recognise my Synology NAS drive. The forum seems to be full of issues and solutions but whatever I tried I could not get anything to work. Each time I tried to add a new drive to Volumio I got either a red or orange error message.

Having gone through a number of topics, I disovered the following which finally got me to a working solution:
SSH into the Volumio box and execute:
sudo showmount -e <>

This revealed the problem, my Synology NAS has a /Music share which is located in /volume1/Music/
As I have a large music collection, I have created subfolders as /volume1/Music/A/, /volume1/Music/B/,… etc. What I was trying to do was add a drive to /volume1/Music/A and each time it failed.

I have however managed to map the root Music folder, so /volume1/Music/ and all is working
The downside is, this is a huge folder which takes a lot of time to index, but it has got me working. and I can now investigate how to get back to those subfolders, hopefully this might give others a useful pointer.

Hey Hugh,

I’ve done almost the same exact thing with my Synology NAS except I used SMB. I created a share called music and under this the folders were the artists names and then the album under that. A file named folder.jpg was placed in each of the artists directory and then cover.jpg under each album folder. Volumio parses the files beautifully.

Thanks, I may need to try SMB, after a few hours of indexing it has reset the artists/albums/tracks count to zero and is still showing the rotating updating icon. Looks like even though I could access the media, it didn’t work.

Yes, ‘sudo showmount -e IPaddress’ can be very useful in showing the actual share name that Volumio “sees” (it is not always what you are expecting), but be aware that:

(1) this is only for NFS shares,
(2) relies on ‘rpcbind’ being present, so will probably fail for NFS v.4

If you are using cifs (Samba), then you can get a similar shares list by using:

smbclient -L IPaddress

again, this does not always work depending on the system being queried.