Conflict with dm_crypt on Raspberry Pi


I’ve searched the forums and web without an answer, so I thought I’d post my issue here to see if anyone had any input.

I’m using a Raspberry Pi. I already have a stable pi running Raspbian so I decided to forego the Volumio img and follow some (understandably) unsupported instructions to install Volumio on my Pi … io-pibang/

I only installed what I was missing. The nginx/php/sqlite setup + alsa and mpd and various configs, git, etc etc. I got Volumio up and running just fine. Love the interface, but I’m seeing a very weird conflict when I run Volumio that prevents me from mounting my luks encrypted drive.

After a few hours of troubleshooting I think I’ve found the culprit…

/var/www/command/ startup & > /dev/null 2>&1

If I boot up my pi with this line in rc.local commented out, then I can mount my luks volume just fine, like I always have

This works great as long as isn’t running at boot!

sudo cryptsetup luksOpen --key-file=/tmp/wd1tb.key /dev/sda  ext_0

However, if that runs at boot time, then I am unable to mount my luks drive. It just hangs forever. Nothing obvious in dmesg. No obvious errors or warnings from cryptsetup using --debug and --verbose

I verified I have ample free RAM before I try and mount the drive with cryptsetup, so it’s not like is eating all my memory and prevents other procs from working.

I don’t know what does (assuming it’s a library watch folder daemon?), but it’s definitely related to this issue. I tried rebooting about 10 times with it disabled and I can mount my luks drive fine. Once I boot with enabled, I can’t mount my luks drive anymore.

Very curious…