Configure Volumio WiFi on Pi without using cabled Ethernet

Lost WiFi connection on a raspberry and lo and behold my router was not listed :question: :question: :question:

Reset to factory and my router is listed…
Think this behaviour has to do with the amount of files I’m asking it to see and it saw it fine when and hadn’t directed it to look at any files yet…

If your router is not listed, just scan again…

on which channel is your wifi router (12 or 13 for instance)?
You may have a REGDOMAIN / CRDA issue: maybe you can set it to your region under SSH as Volumio has no UI yet for that (activate SSH before…see doc link in signature).

and again and again and again and still no joy until amount of files are reduced…

It’s on Channel 11 as 1-10 are full of others people’s routers

Can’t understand how to get to ssh as per your link… nevermind, i’ll just limit the files the wireless raspberry can see as that one is not my main listening system.

should there be double quotes ? or does it matter?

iface wlan0 inet dhcp
wpa-ssid “SSID”
wpa-psk “PASSWORD”

Please refrain from altering config files under SSH or console.
Start fresh from new image and take time to read the UserGuide (see signature below).

Hi guys,

Noob here, in what file do I put the:

allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
wpa-ssid SSID
wpa-psk PASSWORD

My noob instinks says in the config.txt ??

Hi all,

I had the same problem like dangermouse. My Volumio (on RPi3 with in-built WiFi, fresh SD image, Volumio v2.296, No DAC attached) always showed a lot of available WiFi networks around me but never my own one and also manual WiFi configuration was ignored. LAN was always working. I tried a lot of things but finally I obviously found the root cause (at least for my setup) :slight_smile:

My router is an AVM Fritz!Box with WiFi currently running on standard 2.4 GHz, 802.11n+g+b, WPA2 encryption and using automatic channel selection incl. channels 12/13 (to minimize interference with neighbour networks). The typically selected and active main channel was 13 (2,472 GHz) so far. In this setup the Pi with Volumio was never able to see my WiFi.

Then I deactivated the automatic channel selection and selected channel 1 or 6 as a fixed setting. In this setup suddenly my home WiFi became visible and I was able to select and succesfully attach to it. In a next step I activated again the automatic channel selection (without the channel 12/13 option) and this was still working! (active main channel was also in this mode either 1 or 6).

When I then activated again the channel 12/13 option and triggered a new channel selection that led to a setting of channel 13 as main active, then Volumio lost the connection and enabled the internal hotspot instead (without further recovery).

=> My conclusion: Either Volumio or the Pi3 in general (I haven’t tried another distro on it yet) does have a problem with this high WiFi channel 13! So try to avoid them and you may have better success :wink:

And keep in mind if you play around with your WiFi router settings to test this behaviour: After applying a change you may need to restart the Volumio WiFi network as well (either via the network menu while connected to the internal hotspot or by a full reboot).

I hope this helps some of you who have similar problems.

Cheers

@RD07a: if you just read carefully few posts before yours, you have the solution so that higher channel # can be used.
…and also read the manual to enable SSH so that you can make required changes.

Thanks for the hint macmpi. In fact I have read the earlier posts but as the other users in the related posts didn’t see any change to their problem I haven’t tried it out for myself. But I will do it now and will report if it helps for my situation :slight_smile:

Thanks again @macmpi :slight_smile: Obviously for my problem the “correct” solution is indeed the adaption of the regional WiFi settings (using DE for German frequencies). With that now also channel 13 is properly scanned and used and my private network appears as expected in the network search of the Volumio UI :exclamation:

Great to have such supporting experts in this forum :smiley:

its a few years later? bought the raspberrypi 3 and the hifiberry. Can’t get any connection with wifi. LAN is going well.

Just had the same problem and after a few hours I worked out that the standard setup does not include any optional wi-fi channels that are country dependent. The standard base band channels are scanned by default so that is why some networks are listed.
For me, here in Australia, I needed to manually set the country code appropriately to scan all available channels.

Edit the wpasupplicant.config file and add/change the country code as appropriate

sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

country=AU (ISO for Australia, edit/change as appropriate)

ctrl +o ctrl+x To save and exit

reboot and rescan.

I just installed the latest version of Volumio on a RPi 3B+ and I can’t get the WiFi to work either.
It sees my router and it works fine hard wired but the WiFi will not connect.
I have reviewed this thread but a lot of them are pretty old and may not apply any longer. Also I don’t know how to access the config files to check the settings? How do I bring up a terminal so I can check the config files?

Any suggestions on what I can do to resolve this?

@jackcf you need to learn how to ssh into your device to edit config files … straightforward from Linux or Mac, with Windows you will have to use something like Putty. Also, you need to set up your device to allow ssh access

I got it to work after I saw your link on how to enable the device for ssh access and figuring out the username and password.

Is the Hotspot feature required to connect via WiFi?

After reading the Quick Start guide again it sound like it is but I’m not sure.

Thanks.

…same to me.

Rpi or volumio can’t find my wifi network.

I try the solution on post and not work.

If i refresh network on web controll page, i other network and not mine

Priligy Schweiz buy generic cialis Cialis No Me Hizo Efecto can you buy cialis online Viagra Cialis Netdoktor