Compiling drivers for realtek RTL8192CU wifi dongle


I have a cubox-i2 ultra, and Volumio 1.5 goes great on it.
However, I recently tried to use the built-in WiFi (br4329), with mixed luck:
Wifi functions and I am able to connect to my network but the stability of the connection is far from being good.
The stability of the connection is far from being good and I have regular dropouts, and I cannot stream files with resolution higher than CD quality.

I recently bought an ASUS USB N13, rev B1 (realtek RTL8192CU chipset) to try to improve the quality and stability of the wireless connection.
With the drivers included in the kernel, the dongle functions out of the box, but the stability of the connection is worse than with the cubox included adapter!!!
With the help of google, I found that the drivers included in the kernel are buggy (resulting in frequent dropouts) , and that the recommended solution is to compile the drivers from the supplier website to use module 8192cu, instead of kernel supplied rtl8192cu.
After installing the build-essential package, I tried to compile these drivers and have an error, which points to the fact (thank you again, google) that I do not have the kernel headers. I tried but I was not able to locate these headers for volumio 1.5 (cubox-i).

Could any one indicate a way to get these kernel headers?

Else, could the correct drivers be included in the next release/update of volumio?

Thank you