Compatible Wifi Dongle problem

Hi Everybody,
I just bought a WiFi dongle for my Udoo board Quad, to have better performance with the Wifi (the on-board antenna don’t work well).
Like I wrote here:

I bought a WiFi dongle compatible with driver pre-installed; but when the dongle arrived, I found that its drivers are preinstalled on Volumio 1.55 and not on Volumio 1.5 (last version for Udoo).

I download the driver RTL8191su from dlink (it has some product with the same driver) and I followed this guide:
and also this: but the wifi dongle don’t work. I tried with Openelec and it work well!
How can I do?

I also tried to install Volumio 1.55 on the raspberry of my brother to see which driver are installed and I tried to do the same.



I tried to re install all and put a lot numbers of drivers :unamused: but nothing changed.

Could someone help me?


Which specific USB dongle are you using?

This One:

Thanks for the reply!

No one?

I think shouldn’t be not difficult, because is already installed on volumio 1.55.
I wait volumio 2 :smiley:


Does the dongle have an LED that lights up when active? Does that light up?

What is the output of the commands





lsusb Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub Bus 002 Device 003: ID 0bda:8172 Realtek Semiconductor Corp. RTL8191SU 802.11n WLAN Adapter

lsmod Module Size Used by nfsd 62648 0 exportfs 3018 1 nfsd

Yes there is a led, but never turn on or blinking…

Thanks a lot

So…I hope in Volumio 2 :smiley:

The compatability list shows;
Comments: It cost only 12 euros but needs external USB power

And install wicd curses.

You say that the power led doesn’t even light up, so power could be the problem. Did you test the Wifi adapter on an other device like a pc or notebook?

Yes, I try it with Udoo (so the same hardware) and openelec, and it works!
That’s why i thought it don’t need an external power supply.