[Closed] Volumio 2 for Cubox-i is coming

Hi,
I’m happy to announce, that volumio 2 is now running on cubox-i (iMX6 devices).
Due to dependencies, the stock kernel 3.14 could not be used.
Volumio is using kernel version 4.7.2 instead, this means currently headless (no graphical support).

I have a first version running smoothly with a usb dac.
There is an issue with spdif output which needs to be solved (driver loaded, but no sound).
No ETA yet, as this needs to be fixed and more testing needs to be done.

A big THANKYOU to forum member Gribouille, who lent me a cubox-i2ex to configure the kernel, u-boot and develop the build scripts.

Fabulous news.

Thank you so much for all the time and effort you are taking to support the Cubox-i. I had given up hope of finding a use for my i2 so this has really made my day. Hopefully spdif support will arrive for Christmas.

Thomas

Great news! I was waiting for this image for a long time.
:smiley: :smiley: :smiley:

Quick feedback: spdif port issue has been resolved, the Volumio 2 port can now be finalized…

Will the final version still be headless or will it have graphical support? I’m hoping it’s the latter.

No graphical support, sorry. There is nothing we can do until the kernel supports it and that will be after our first release…

Does the image run on Cubox-i4Pro as well?
How can we download image file?
Thanks

It should… I’ll build a beta image, so you can give us your feedbacks… (still a WIP, but you should have an idea…)

Thank you for this !!

Also really looking forward to this, even just a WIP.

Here you are:
updates.volumio.org/cuboxi/volum … xi.img.zip

let us know how it works… If everything is allright we’ll release it …

PS: Know issue, no wifi

Thank you guys for all the work done so far, will also test and give feedback asap.

My issues with .991cubox:

  • I can’t set the password for my wireless (there doesn’t seem to be an option to do that)
  • My USB DAC blinks its led (never saw that before), and is not recognized so I can’t set it (Meridian Explorer)

WIFI is a known issue on cubox. Could you suggest how to enable it? Got no reply from solidrun…

Don’t know about USB… Mine works, I will look at it

Maybe it is possible via the console?

Thanks! Take it easy! :smiley: If I can supply information, let me know. (BTW: It is recognized on my R Pi, allas without sound)

Thanks again for all the work you put into this.

A few things that I noticed while trying out V 0.991 on Cubox-i2eX with USB-DAC ‘QNKTC’

  • playing mp3 from USB and “Internal Storage” works ok
  • playing flac from USB and “Internal Storage” works ok
  • initial startup-sound playing ok
  • no sound output, or error message with radio stream mms://apasf.apa.at/fm4_live_worldwide which worked fine on 1.5 Although the Stream is shown as being played, the Play button is not changing into the Stop/Pause button. Stream plays ok with VLC on same network. Could this maye be a timeout issue, as the stream used to take about 10 seconds to start playing with V1.5?

  • Webradio: Shoutcast and Dirble folders cannot be opened (I’m unsure if a plugin is needed for that?)

  • couldn’t locate the right place to copy *.pls Playlists into in order to carry them over from 1.5. On 1.5 I used to copy with Windows via Samba-Share into the Webradio folder. Now there is only a folder ‘Internal Storage’ is this the place, where it is ment to go?

  • getting “failed to decode” error for radio streams mp3stream1.apasf.apa.at:8000 which used to work on 1.5

  • Could not identify proper settings to enable volume control (used to have Mixer type: “Software” in 1.5 which is gone now), tried all options for mixer control.

  • Volume options / mixer control by default has PCM set. When opening drop-down, “Audio-widget” is shown twice. Once the setting is changed, returning to PCM-Option is not possible, which somehow doesn’t look right.

  • no sound when streaming via Airplay

  • currently unable to connect to Synology NAS (NFS), although this might be due to special characters in password. Will test this again tomorrow. Had a similar problem with 1.5.

  • Also - mount not shown in GUI. Restart also doesn’t help showing mount in GUI

Sorry in advance, should I have listed things that are already known bugs.

What a great re-work of volumio!
First impressions after few hours playing with it on cubox-i2 ultra with Audiolab MDAC (USB)

  • NAS Mount: NFS share OK, indexing >15k files OK
  • Startup sound: OK
  • ssh connection: OK
  • Album art: in between
    files are located on the NAS mount, as “folder.jpg” in their respective album folders.
    Can see the images on the playback tab, but not in the library tab (bay album or by artist categories
  • plugins: ??
    Can see none from fresh install (seems OK). No possibility search for it
  • Reboot: NOK - strange
    reboot from web UI. All seems to get back up normally (startup sound) but volumio cannot be reached either via ping or via webUI.
    Need to pull power plug to have it be able to reach volumio again
  • web radios: NOK
    added urls from m3u files (known to be working on iTunes, vlc, archphile distro) but got the error it cannot decode the stream
  • additional package install (apt-get): NOK
    want to compile drivers (rtl8812au) for wifi adapter (internal cubox wifi chip has never been good for for me - perf and stability issues)
    It points to raspbian repos (correct??) and repos cannot be reached
    Any help on this one would be appreciated

I understand the cubox version is a WIP.
Thanx for the great work

First of all, it’s very exciting to see Volumio in progress. So thank you for your great work.
I launched volumio 2 on my Hummingboard i2. I tried with its spdif output only. The good news is It works.
Of course, as it is has already pointed out radio streaming doesn’t work.
Another problem which may be has not been mentioned yet is I’m unable to update a specific folder, the menu has disapeared if I compare to Volumio 1.5. If you receive daily podcasts, it’s not convenient to rescan all the folders when only one folder has changed and must be updated.
So I hope you will find the time to add this function. Thank you again.

HI Michelangelo, devs

It seems there are quite some updates on volumio lately.
Anything coming up for cubox-i?

If I may ask, having the kernel headers in the image would be much welcome.
Thanks and keep up the good work!

We have not finished development on cubox-i as there is still an issue with wifi.
Linux headers should be no problem as we compile ourselves, I might drop them into /usr as a tar-file

-Gé-