[Closed] Volumio 2 Beta versions for Odroid

I did some rebooting over web-interface, aprox. 10x “reboot” and aprox. 10x “power off” with unplugging the power: no problems!

The average reboot only takes 30 seconds from clicking reboot to refresh of webinterface :astonished:

Mounting state (true/false) of the SMB-Share seams to be random with a bit more true’s than false’s, maybe 70:30 - i checked after each reboot :wink:

Some more notes:
Startup sound is really low, compared to the normal output - i could hardly hear it without changing the amplifier volume.

and as a seasoned V1.55-user:
The Queue (formerly known as Playlist) is empty after reboot
The current song is not highlighted anymore

OK, these are all non-odroid related issues, so instead of me playing the mitm, better add them as issues on the list at http://github.com/volumio/Volumio2 so this get checked/ classified by the developers.

did someone already verify if a XMOS USB Dac with ES9018 work with the Odroid C2 Volumio 2 derivate from gkkpch ? I want to change from RPI 1b and V1.55 to it.
Thanks a lot.

Yes, it will work. XMOS dac’s rely on the usb audio driver and that one is included.
And… it is not “derivat”, the C2 image is built from exactly the same repo and as such as original as the pi ones :mrgreen: One of the things that makes Volumio 2 so nice…

Sorry in advance. Very new to this.
I have Volumio2 RC-1 fix 23/4/16 on Odroid C2. Very nice and quick boot.
Plays fine through one of my USB DACs (Musical Fidelity M1-Clic). Volumio2 Detects a USB DAC (under output device) and Volume Mixer control is disabled.

With my Douk 384/32 bit USB DAC, Volumio2 Detects a “HIFIRef” (under output device) and Volume Mixer control is 2 option, both “iAP interface”. 1 of them leads to red error messages saying failure to decode files.
The other seems to output PCM at correct resolution [based on LEDS on DAC] but no sound from the RCAs.

Do I need to enable some kind of driver? If so how.

(Douk DAC works fine from PC with driver and Foobar)
Apologies again if this is a silly question, in the wrong forum…

No, it should actually work without any changes.
I’m a bit puzzled because the USB DACs are being driven by the standard linux snd-audio-usb module.
Have you tried using alsamixer to raise the volume? (F6 lets you pick the sound card)

Thanks gkkpch!
So with 30 mins of googling…installed Bitvise, and learned how to use a terminal and alsamixer…and found the “2nd iAP” volume mixer was muted. Weird.
So now it plays my flacs fine.
But…my DSD 64 files (read as PCM on the DAC) play with lots of hiss. Any ideas? Is Volumio2 intended to play DSD via USB DAC? The DAC itself plays them ok from Foobar//windows.

I’ve seen it before myself, that’s why I asked. Not a clue yet why that happens

No, unfortunately I don’t have such device, so I can’t test. Please open an issue on http://github.com/volumio/Volumio2 under “issues”.

Hi Gé,

I have the same problem with my C1+ (hang while booting), I can’t webaccess to the 0.861RC1.
EDIT : No more success with the 0.858 but 1.55.1 works like a charm

Could you please build a RC1fix for the C1+ ?

Many thanks


Chris, the problem I fixed was C2-related. If boot stalls on a C1+, then it must be something else.
I have not experienced any issues with the C1+, but that does not mean there couldn’t be any.
Will flash an image and have a look. Do you use wifi or ethernet?
What kind of DAC? Did you connect a monitor or TV and see where it gets stuck?

EDIT An image has been built from the same software version as the C2 fix, could you try that one first please.
Perhaps there is a difference, as the C2 was not fixed from the same version as the original RC1.
It has been been uploaded a couple of minutes ago.


I will try as soon as I have downloaded the .img and installed it on my µsd.

My OC1+ is ethernet connected (fixed IP on router via mac address) + USB DAC Audio-gd NFB1 (amanero combo)


Well… I still can’t access to Volumio2 via IP.

  • Red light and blue heart beat work fine
  • I’ve tried with my Edimax wifi dongle without more success.
  • nmap doesn’t show my wibrain.
  • can’t access with ssh

Re trying with Volumio1, everything works fine.


weird, before I uploaded I did check the image and on a C1+ it works perfectly.
Does it boot without anything connected?
Re. network, so you are using DHCP, but the router will give a fixed IP?

@gkkpch: I just tried to download, wrote the latest C2 image - fixed one using Win32DiskImager to micro SD card then insert it into C2 card slot. There is nothing on the TV screen, few seconds I heard a sound notification the screen is still black. The blue led is heart beat blinking, the led red is on constantly.

Can you advise what to do for next?

15 min later I turned it off then reboot after 30s the issue is the same :frowning:


There is no screen output, the C1/C2 are set up headless.
I have to admit that this has been neglected a bit because I used the UART interface while creating and testing the build script. So obviously console output is missing and should be added in a next version.

Can you check your DHCP server to see if an IP address has been reserved (or scan the network with a windows tool like IP Scanner?
Enter that one in a browser on your local network.

Did you try Volumio 1.55, did that work?

I open the wifi router where I saw the IP that I tried to connect it via browser but failed. Even to try with the Volumio UI on android smartphone but failed too… :frowning: …no more idea now.

In case there is an IP address, then Volumio 2 booted ok.
Can you try to ssh using volumio/volumio as user and password?

I used all my mSD card for other things, let me find another one to make again then I will inform you Sir! Tks.

I used Advanced IP Scanner v2 to scan that there is no IP for Volumio. The IP I said hours ago is the TV ip (my TV is smart one that it is connected to the home network all the times).
The red led is on constantly. The blue led is blinking like heartbeat.
Sorry for this, thanks to advise me for the next !