Cifs trouble mounting a timecapsule containing my music

Hello, I am attempting to use Volumio as my music server and am running into a rather frustrating problem.
background and configuration:
• Raspberry Pi with system up to date via “apt-get update”, “apt-get fist-upgrade”, and “dpi-update”
• WIFI configured and working
• Music on a 2TB Apple airport Timecapsule
• Volumio accessible over the web and ssh
• Timecapsule successfully mountable via mount or fstab

The problem:
• cifs mounting requires extra parameters to successfully mount above and beyond username and password i.e.:

// /mnt/USB/usb1 cifs user=bruce,pass=password,sec=ntlm,rw,uid=1000,iocharset=utf8 0 0
• Volumio has no where to enter the extra parameters in the web UI
• the /mnt/NAS area seems locked so that I can not manually add a device there outside of the Volumio web UI

Any help in getting this filesystem recognized by Volumio would be very much appreciated.

Change your Tcapsule to manage the disk using users (i couldnt make it to work with the tc pass…) Create the user at TC using airpoirt utility, once completed.

Connect with your mac to the TC using that user, if the files are not visible, reconfigure it as it was and connect again, move the files to the shared directory on it (that will make it visible to anyone)

Re configure it to be managed by user access

Try with this command (I changed your NFS directory to the NAS so it then becomes visible to Volumio):

from a terminal:
ssh -l volumio volumioip

sudo mkdir /mnt/NAS/Music
sudo chmod 777 /mnt/NAS
sudo chmod 777 /mnt/NAS/Music

// --> You might need to install cifs utils:
if yes then use the following commands:
sudo apt-get update
sudo apt-get install cifs-utils

sudo mount.cifs / /mnt/NAS/Music -v -o user=userID,pass=password,perm,rw,iocharset=utf8,sec=ntlm NAS

YOu can check if it got mounted running this command:
df -h

This creates the NAS link, then go to the webUI and go to any NAS drive you have click on update to trigger the update process…
Wait some seconds-minutes and you should be able to see at the NAS option the Music Directory …

Hope this helps

I tried to connect too and when i enter the sudu mount link I am getting a bad UNC error

With Volumio 3 you should be using the options you get in the “sources” menu, “add network drive”.
If you can’t get it to work, make a screenshot of what you have entered and post it here.

these are my settings I am trying to connect an apple time capsule

You were answering to a cifs related post, now you are showing that you are using nfs ???
Please be a bit clearer with what you want to achieve, I’m confused :wink:

my doubts are with the path you entered, you need to show the /etc/exports file from the NFS host sharing the flac files.

Any more info on this, perhaps you wish to add a log?
sending a log
Preferably shortly after entering the data and the failure to connect.

Can you send me clear instruction on how to connect to An Apple TIme Capsule with 2tb drive inside. either using the UI or the ssh using the Mac OS Monterey Terminal?

Honestly I can’t, I don’t have Apple equipment, but that wouldn’t stop you from helping us to help you.
Why not do as suggested and then we take it from there. Make a screenshot of what you have, save it and then prepare a log.
Also tell us exactly what the share name on your apple device is.

Have the MAC but not a time capsule. I know in combi with NFS the time machine won’t work. If you try CIFS, did you also add vers=1.0 as option?

ro,sec=ntlmv2,vers=1.0 or
ro,sec=ntlmssp,vers=1.0 or

I tried that but all it shows for mounted is a red x no error messages though.

Hard to provide additional support, due to missing hardware.
Only some open doors left:
ip correct?
Path to share correct?
Are you able to manually mount the share?

I have also tried using this ssh command in terminal
sudo mount.cifs // /mnt/NAS/Music -v -o user=berubetime,pass=pass,perm,rw,iocharset=utf8,sec=ntlmv2,vers=1.0 NAS

Did that work? If not, what error do you get.
Same with Volumio GUI, create a log and we will see.

You are causing a lot of confusion, on the share name.

  • 1st Screenshot shows: Data/flac-files
  • Your manual mount shows: Data/Music
  • 2nd Screenshot shows: Data/Music
    You took a 1-1 copy form internet looking at the end “NAS” of your manual mount.
    Even the ip address got some new additions.

this is what I got from the ssh command

volumio@volumio:~$ sudo mount.cifs // /mnt/NAS/Music -v -o user=berubetime,pass=pass,perm,rw,iocharset=utf8,sec=ntlmv2,vers=1.0 NAS
mount.cifs kernel mount options: ip=,unc=\\Data,perm,iocharset=utf8,sec=ntlmv2,vers=1.0,user=berubetime,prefixpath=Music,pass=********
mount error(13): Permission denied

here is what I got from the GUI

 volumio : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/mount -t cifs -o username=berubetime,password=pass,ro,dir_mode=0777,file_mode=0666,iocharset=utf8,noauto,soft,ro,sec=ntlmv2,vers=1.0 // /mnt/NAS/TIME
pam_unix(sudo:session): session opened for user root by (uid=0)
CIFS: Attempting to mount //
CIFS: VFS: Use of the less secure dialect vers=1.0 is not recommended unless required for access to very old servers
pam_unix(sudo:session): session closed for user root
info: An error occurred mounting the new share. Rolling back configuration
CIFS: Status code returned 0xc000006d NT_STATUS_LOGON_FAILURE
CIFS: VFS: \\ Send error in SessSetup = -13
CIFS: VFS: cifs_mount failed w/return code = -13

at least you can raise vers=1.0 to vers=2.0
error 13 indicates permission denied.
Either the users is not setup correctly to access the share, you have typo’s
replace sec=ntlmv2 with sec=ntlmssp

I tried all your suggestions and it still is not working do you have the code for the openssh?

Other than the basics like creating a user account on the 2TB Time Capsule does any other settings needs to be setup? I can connect to it no problem with my phone and computer