cifs trouble mounting a timecapsule containing my music

Hello, I am attempting to use Volumio as my music server and am running into a rather frustrating problem.
background and configuration:
• Raspberry Pi with system up to date via “apt-get update”, “apt-get fist-upgrade”, and “dpi-update”
• WIFI configured and working
• Music on a 2TB Apple airport Timecapsule
• Volumio accessible over the web and ssh
• Timecapsule successfully mountable via mount or fstab

The problem:
• cifs mounting requires extra parameters to successfully mount above and beyond username and password i.e.:

//10.0.1.1/Data/Music /mnt/USB/usb1 cifs user=bruce,pass=password,sec=ntlm,rw,uid=1000,iocharset=utf8 0 0
• Volumio has no where to enter the extra parameters in the web UI
• the /mnt/NAS area seems locked so that I can not manually add a device there outside of the Volumio web UI

Any help in getting this filesystem recognized by Volumio would be very much appreciated.

Change your Tcapsule to manage the disk using users (i couldnt make it to work with the tc pass…) Create the user at TC using airpoirt utility, once completed.

Connect with your mac to the TC using that user, if the files are not visible, reconfigure it as it was and connect again, move the files to the shared directory on it (that will make it visible to anyone)

Re configure it to be managed by user access

Try with this command (I changed your NFS directory to the NAS so it then becomes visible to Volumio):

from a terminal:
ssh -l volumio volumioip

sudo mkdir /mnt/NAS/Music
sudo chmod 777 /mnt/NAS
sudo chmod 777 /mnt/NAS/Music

// --> You might need to install cifs utils:
if yes then use the following commands:
sudo apt-get update
sudo apt-get install cifs-utils

sudo mount.cifs /10.0.1.1/Data/Music /mnt/NAS/Music -v -o user=userID,pass=password,perm,rw,iocharset=utf8,sec=ntlm NAS

YOu can check if it got mounted running this command:
df -h

This creates the NAS link, then go to the webUI and go to any NAS drive you have click on update to trigger the update process…
Wait some seconds-minutes and you should be able to see at the NAS option the Music Directory …

Hope this helps