Changing output device in mpd.conf


I’m running Volumio 2.323 on a Raspberry Pi 2 with a Hifiberry Digi+ Pro, HW 1.2 outputting SPDIF to an amplifier.

When I try to play a song through the web interface, I see an alert that reads:

Error Failed to open "alsa" [alsa]; Failed to open ALSA device "hw:1,0": No such file or directory

When I check to see what the hardware address of my DAC should be, it looks like it should actually be hw0,0, I think:

volumio@music:/etc$ aplay -l **** List of PLAYBACK Hardware Devices **** card 0: sndrpihifiberry [snd_rpi_hifiberry_digi], device 0: HiFiBerry Digi+ Pro HiFi wm8804-spdif-0 [] Subdevices: 1/1 Subdevice #0: subdevice #0

I found what looks like the right settings in /etc/mpd.conf:

audio_output { type "alsa" name "alsa" device "hw:1,0" dop "no" }
but if I edit mpd.conf, it gets rewritten when I restart Volumio, so I must need to change it at a higher level.

How can I change what device ALSA tries to use?


You should have enabled the I2S DAC from VolumioUi, reboot and then everything would have be fine…

Looking under Playback Options > Audio Output > I2S DAC, the DAC was already enabled.

I tried disabling it, reenabling it, and then rebooting, but the same ALSA hw1,0 error occurs.

Still stuck, I think.

Did you edit the file /boot/config.txt ?
If yes, restore the line dtparam=audio=on

If not, disable i2s and after reboot just select hifiberry

Here’s my /boot/config.txt:

initramfs volumio.initrd

#### Volumio i2s setting below: do not alter ####

(I just tried resetting Volumio with the factory reset button.)

I’m not sure what happened, but I’ve got it working now.

For whatever reason, it seems the DAC wasn’t detected previously, but now it is.

Thanks for the help!