CD ripping, can't choose destination

Hi,

I have ripped at least 20 CDs without problem, but now when i try to RIP a CD i can no more choose the destination, it only shows me the “Musica_” option which is my HDD name with an underscore. If i choose this option it will not RIP the CD and it will instantly reject it.
GUI

ssh terminal on /mnt/USB/
terminal

Hi Paolo, sorry for the trouble!
It seems that a new partition has been created. I wonder why.
What is inside of this folder?

Hi,
sorry for the delay.
Inside “Musica_” there is nothing.

Paolo- Thanks for posting this. I am curious to learn what is causing it.

I have also had an experience similar to this. Are you using Nanosound CD to extract cd’s?
My SSD drive had a directory called VolumioLib where my music library was stored.
Recently I discovered that there was a new directory called VolumioLib_ which contains the music library and the original VolumioLib (no underscore) is still there but empty.

I’m able to specify VolumioLib_ (with underscore) in the extraction path and Nanosound CD will extract to it.
I’m curious how this was created. I haven’t done anything intentional with the structure of that drive.

Side Note: there is also an EFI directory that was created when I initially formatted the drive. It was magically cloned as EFI_ as well.

A little more detail

volumio@volumio-listening-room:/media$ ls
EFI EFI_ VolumioLib VolumioLib_
volumio@volumio-listening-room:/media$ ls -al
total 161
drwxrwxrwx 1 root root 4096 Sep 20 14:12 .
drwxrwxrwx 1 root root 4096 Sep 7 22:39 …
drwx------ 2 root root 4096 Sep 9 01:18 EFI
drwxrwxrwx 2 volumio volumio 512 Jan 1 1970 EFI_
drwx------ 2 root root 4096 Sep 9 01:18 VolumioLib
drwxr-xr-x 1 root root 131072 Jan 1 1970 VolumioLib_

Noticing that all of the directories ending with _ (underscore) are dated Jan 1 1970, for both my system and Paolo’s.

Hi,
Any ideas on how to solve this issue?

Paolo, do you have installed (now or previously) the NanoSound CD Plugin?
What are you using? The MyVolumio plugin or the NanoSound CD Plugin?

I have Volumio Primo, I haven’t installed any plugin.

This is not a solution, but I always rip to the internal memory, and then just moved them to where I want them with a computer.

Hi,

I found out that it never wrote the music to the HDD but to internal memory.

I formatted the HDD to TOSHIBA-HDD and i moved the music from /mnt/USB/Musica to /mnt/USB/TOSHIBA-HDD.

I still can’t RIP the music to the HDD. When i choose the TOSHIBA-HDD destination from the UI it works for a few seconds then it ejects the CD.

I attach the log from volumio.local/dev/

log.txt (13.4 KB)

Thanks for your help.

I have a similar problem: with MyVolumio subscription, and no plugin installed, with a NAS mounted and working, I can not rip to the NAS, only Internal Memory.

Any advice, pelase?

Is the NAS in SMB protocol connection?
Can you see it in “Music library” menu?
Volumio device wired or wifi?

Davide
Volumio tech support

Thank you for the reply.
Yes, it’s in SMB protocol, and as I said, it’s mounted and working, meaning I can see it in “Music library” menu, navigate the folders and play tracks.
All is working as it should, as far as I can tell, except riping a CD to the NAS.
Volumio device is a Raspberry Pi 4 and it’s connected with ethernet, as is the NAS, a Raspberry Pi 3 with OpenMediaVault NAS system.

Hi,

maybe the mount is read only ?

use -rw under options when mounting.

br
Josef

Thank you for your help, but did not work.
On the NAS, the shared folder is set to be read/write/executable.
In the Sources menu of Volumio, if I insert -rw in the NAS settings it gives an “invalid parameter” error.