Can't see local files on SD

I wanted to store some music on the SD card in my RPi3 (I run Volumio off the SD card). Volumio creates a directory that appears as “Internal Storage” on a Windows network (and is at /data/INTERNAL on the file system). So I created a subdirectory called Test and copied a few FLAC files to it. I could see the files from my Windows PC as well as via SSH to the RPi3.

But I’m struggling to access the files from Volumio (2.201). The only place I could find them was if I selected Browse/Music Library. There I could see two folder icons, one for NAS and the other for “Local Files” or something like that. When I clicked on Local Files I could see the Test folder, but clicking that showed nothing - none of the FLAC files was listed.

So I thought perhaps I should reboot the system, which I did. But now the weird thing is that under Music Library, I can see only the NAS icon, and no Local Files icon (which is why I can’t be precise about the name that appeared). I can again see the Test files via the Windows network browser and via SSH, so they are definitely there.

What do I need to do to play the files on the SD card?

Can you try copying a flac file into the top level of the directory & see if you can see that in Volumio. Also, what are the permissions on your folder ‘test’?

Ah, OK, must be a permissions thing. I can see the files when they’re in the top level of Internal.

I don’t have much Linux experience. How would I set the permissions for folders within Internal? I thought permissions would somehow just be inherited.

You’ll need to do it from a ssh session. Can you post the result of ‘ls -la’ in the ‘/data/INTERNAL’ directory?

Here’s what I get:

volumio@volumio:/data/INTERNAL$ ls -la total 165028 drwxrwxrwx 1 root root 4096 Jul 28 08:53 . drwxr-xr-x 1 volumio volumio 4096 Jul 27 06:29 .. -rwxr--r-- 1 nobody nogroup 22647242 Dec 30 2015 01. Test.flac -rwxr--r-- 1 nobody nogroup 70012343 Jul 27 06:08 02. Test.flac -rwxr--r-- 1 nobody nogroup 76312081 May 21 2016 03. Test.flac drwxr-xr-x 2 nobody nogroup 4096 Jul 28 08:53 Test

Sorry, and the permissions of the files in ‘Test’ too please.

Here’s the information:

volumio@volumio:/data/INTERNAL/Test$ ls -la total 165024 drwxr-xr-x 2 nobody nogroup 4096 Jul 28 11:54 . drwxrwxrwx 1 root root 4096 Jul 28 08:53 .. -rwxr--r-- 1 nobody nogroup 22647242 Dec 30 2015 01. Test.flac -rwxr--r-- 1 nobody nogroup 70012343 Jul 27 06:08 02. Test.flac -rwxr--r-- 1 nobody nogroup 76312081 May 21 2016 03. Test.flac
If it’s relevant, I believe I did the copying of files to the SD card via Windows, and not ssh.

Hmm, I don’t understand why that doesn’t work. If I do the same thing here, then it does work. You could try changing the user and group to ‘volumio’.

sudo chown -R volumio Test sudo chgrp -R volumio Test

Have you altered anything in /etc/samba/smb.conf?

No, didn’t change anything in smb.conf.

It’s a standard installation, driving a Hifiberry Digi+. Of course, there is a change from Volumio defaults to enable SSH (done via the /DEV page).

Just out of curiosity, I tried making the samba share subdirectory from Windows, and yes it does lead to the behaviour you describe :slight_smile:. There are no permission differences between the Windows created one & the Linux created one, yet Volumio does not show the contents. Now I do know that Windows manipulating Linux file systems may lead to unforeseen consequences (works fine the other way round) although I’ve never come across it personally.

Would you mind creating a directory on your RPi from an ssh session:

mkdir Test2

and then add your files to this directory from Windows as usual. Does this work correctly from Volumio?

I can create the directory via ssh, but after that I can’t write to it from Windows

volumio@volumio:/data/INTERNAL$ ls -la total 165032 drwxrwxrwx 1 root root 4096 Jul 29 15:18 . drwxr-xr-x 1 volumio volumio 4096 Jul 27 06:29 .. -rwxr--r-- 1 nobody nogroup 22647242 Dec 30 2015 01. Test.flac -rwxr--r-- 1 nobody nogroup 70012343 Jul 27 06:08 02. Test.flac -rwxr--r-- 1 nobody nogroup 76312081 May 21 2016 03. Test.flac drwxr-xr-x 2 nobody nogroup 4096 Jul 28 11:54 Test drwxr-xr-x 2 volumio volumio 4096 Jul 29 15:18 Test2

No write permissions. Give the directory permissions for full access for everyone (like the parent /data/INTERNAL) to check it works ok.

cd /data/INTERNAL sudo chmod 777 Test2

Assuming that it works, you might want to read up on permissions to see if you’re happy leaving full access like this. Also, read up on Windows accessing samba shares on linux as a user or group called volumio … sorry my Windows knowledge is getting a bit rusty.

Assuming I can find a way to do it, would it be preferable to change the owner of all the files to volumio (user)/volumio (group)?

It doesn’t matter what the owner/group is if you set the permissions to 777 … that allows the whole world & it’s dog to access the files (not literally of course, the files are still behind a LAN address not open to the internet).

Note that my comment about Windows accessing volumio as a user/group was as an alternative to the 777 permissions … I was trying to give you alternative ways of solving your problem, but probably just confusing you. My apologies.

No, I appreciate the suggestions. I should have been clearer: my thinking was that as alternative to “chmod 777”, if I could make the owner/group volumio/volumio (and not change anything else) then perhaps it would keep out at least some of the world’s stray dogs.