Can't play single song, only whole folder

Feeling a little bit stupid but it seems that I can’t play a single track from a folder, only the whole folder (!).

Not sure why this happens and given I am pretty new to volumio I’m not even sure where are the logs in order to check them. Any help is appreciated!

Video of what is happening available here:

Volumio Information

Volumio Version: 2.861
Hardware: Raspberry Pi 4 4GB

first add it to queue there you can always start it :wink: but it seems like a little bug…

Makes no sense. And what about folders that I don’t see the “play folder” option?

Am the only one facing this issue?


Try to change Playback Mode to Single

Settings->Playback Options -> Playback Mode

Nada. Still the same.

Restart ?

Is this an local album or Spotify etc. album ?

Works three dot menu and Play from there ?

Version of Volumio ?

Restarted but made not difference. This problem occurs (at least) in folders that are accessible from a media server. I will try now to mount the disk.

Ok, the bug seems to exist only when accessing folders from the “Media Servers” menu. After mounting the network disk and navigating through the Library the single song selection works.

It worked long time ago. In previous version. I noticed it occurs at least one year in all version.

Hiya - this problem seems to occur when the music folder you select (I also have my library ordered by folders, not artist, title, etc) has a sub-folder: in your case “Artwork” - get rid of this subfolder and it should solve it.

This is a long time shortcoming with Volumio… not being able to play or select (to queue) single tracks from Media Servers.