Can't play file with " character in name


I started to rip my CD box with the complete works of Verdi. The music files (ogg) are placed on a NAS, , and I make playlists in Volumio.

I didn’t notice any problems until I reached Rigoletto, where all files except the Sinfonia have ‘"’ in the names. And he playlist only contained the one file without.

I can’t play the file either, so it’s not only a playlist problem.

Is this a knwon limitation? Can it be fixed (other than renaming all the files), or does a workaround exist?

Tried volumio from this summer, and upgraded to 2.348 to test, but problem persists.

Nobody with similar experiences, or hint at what to do?

To recap, I founf out that I can’t play songs where there is a " (apostrophe) in the title. Also, the title isn’t even transferre to the queue.

I’m not sure that’s the only problem character, so I’m wary to just change file names, as I don’t know the size of the problem.

I logged in w/ ssh but nothing is logged. In fact ISTM that the log just stops early when I try to play a fiel with the problem.

ANy hints as what to do?

Me too stumbled upon this problem.

From the 9 cd’s i’ve ripped to aiff all the foldernames and filenames containing apostrophes are not visible after ‘Update’ and ‘Rescan’ in the Music Library. Reboot didn’t solve the issue either.

Volumio 2.348, Rpi3, Hifiberry (XLR), Music Library on Nas.

This is a general computer problem rather than specifically Volumio … have a Google

Could you please tell which general computer problem I should google?

Just for reference, I played some of the exact same file on my laptop w/o any problem, from the same NAS.

I noticed the problem too and BTW there is also a problem with colons (:slight_smile: in the filename which is commonly used with classical music (I usually rip CDs with a Linux notebook, maybe this doesn’t happen on Windows) .
I solved these issues with a shell command which replaces quotation marks and colons by spaces.