Can't get past volumio@volumio:~$

Ok, I am 100%new to this.

I used etcher to flash my SD card.

The latest download of Volumio.

I get to volumio@volumio:~$

Then nothing… I can’t make it do anything.

Using Pi 3A+

Any help would be appreciated…

Scroll down a bit, you don’t need to connect directly via that prompt…

Thank you for your help…

I suppose that I should have said that I am trying to install it as a stand alone operating syatem.

Does that make a difference in what I should do?

No. Volumio IS an operating system by itself. There is no other way to install it.

It is designed to run headless though, and its functions can be controlled via the webUI or app. Scroll down a bit in the Quick Start Guide to read how to connect to it.

Ok, I have read all the way down now…

Only there is a step that I can’t do.

It says to connect ethernet cable.

There is no place to plug ethernet cable on Pi3 A+…

Sorry if I am missing something. As I said, I am completely new to this Pi.

No problem.
When it starts, Volumio creates its own wireless network called Volumio. Connect to it (pw: volumio2).
You will see the user interface appear.

Then see: … Guide.html

EXCELLENT!! Thanks to all of your help, I am now able to run Volumio through my PC and also my phone.

For this help, I thank you again!

However, now I am wanting to be able to access the desktop on the Pi alone.

So that the Pi acts independently.

How do I get it to boot directly to the desktop using only the Pi??

I think that I am not clear what I want. Sorry, my English is so broken.

I want the Pi to behave like this Sony HAP-S1 player.

All self contained and not requiring web browser on phone, tablet, or PC.

If it cannot be self contained then I must find something other than Volumio.

Thanks for any help you can give.

You would need to purchase a touchscreen display and use the ‘touchscreen plugin.’

Maybe you can check this project:

Ok, so now I have the screen…

This one:

It is assembled now.

But, I do not see how to get it working…

I installed the touch screen plugin.

Still nothing…

Please help?

@Arjan Singh
Did you run the installer provided by pimoroni? If so, did any errors occur?
Does the display show the command line with the login prompt?

When you installed the touch display plugin did any error messages show up?
Are you you able to enable the touch display plugin or do you get an error message?

In case you should have received error messages please post them and describe when they did occur.

Also please post the result of cat /boot/config.txt

I have installed Raspbian from the NOOBS download.

I ran installer on that. It works!

I swapped to the Volumio SD card. And then tried to figure out how to run installer.

There is no terminal? How can I run installer?

I was also told to download this Windows program “putty”…

I have it now. But, I do not know what to do with it.

When I installed touchscreen, there are no errors showing.

But, also nothing on the screen anyway. I enabled the touchscreen plugin with no errors also.

Sorry, I am so new, that I don’t know much…

You need to enable SSH on Volumio. Look for the section “How to enable SSH” here

Then start putty and connect to Volumio via SSH. Use the IP address of your Volumio and the user “volumio”. Password is also “volumio” (without the quotes :wink: ).

From there you can run pimoroni’s installer. After that a reboot will be in order I guess. If the display still should not work, connect via SSH again, run cat /boot/config.txt and post the result.

During the installation process watch out for error messages, copy them and post them here, too.

P.S. On how to use putty there are a lot of descriptions on the web (e.g. or

Ok, it does this:

volumio@muzik-pi:~$ cat /boot/config.txt
initramfs volumio.initrd

Then also this:

login as: volumio
volumio@’s password:
/_ \ __
__ __ //\ \ __ __ ___ ___ /_\ ___
/\ /\ \ / __\\ \ \ /\ \/\ \ /' __ __\/\ \ / __
\ \ _/ |/\ \L\ \
\ _\ \ _\ /\ /\ /\ \ \ /\ \L\
\ _
/ \ _//_\ _/\ _\ _\ _\ _\ _/
// // // // /////////___/

         Free Audiophile Linux Music Player - Version 2.0

      C 2015 Michelangelo Guarise - Volumio Team -

Volumio Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sat Sep 21 04:52:23 2019 from
volumio@muzik-pi:~$ curl | bash
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 39585 100 39585 0 0 35053 0 0:00:01 0:00:01 --:–:-- 35093

This script will install everything needed to use

Always be careful when running scripts and commands copied
from the internet. Ensure they are from a trusted source.

If you want to see what this script does before running it,
you should run: 'curl’

Your operating system is not supported, sorry!

volumio@muzik-pi:~$ login as: volumio

Too bad, it seems officially only Rasbian and RetroPie are supported. In the script that gets executed when you run curl | bash Volumio is explicitely excluded as a supported operating system! :frowning:

So be warned that you might mess up your system if you proceed and try the following:

After connecting to Volumio via SSH run

git clone
cd hyperpixel4
sudo ./

This way there should be no check for excluded operating systems. But be aware that there is no guarantee the display will work.