Can't figure out how to get my display to go blank at idle

I’m wondering if I somehow lost the ability for the display to go blank at idle. I’m using volumio 3.251 on a pi4 with the waveshare 7.9 widescreen. I have the now playing, touch screen, and peppymeter plugin. I have the timeout set to the default 120 seconds. It refuses to blank. I thought peppy or now playing was to blame but it still won’t blank with them disabled. It will just show the last song I played indefinitely. It has never worked so maybe I’m missing something in my configuration.

Where should I start?

Do you have the same issue on a fresh Volumio system with just the Touch Display plugin installed?

Please post the results of

cat /boot/config.txt

cat /boot/userconfig.txt

im not sure it worked before the plugins

config.txt
initramfs volumio.initrd
gpu_mem=32
max_usb_current=1
dtparam=audio=on
audio_pwm_mode=2
dtparam=i2c_arm=on
disable_splash=1
hdmi_force_hotplug=1
force_eeprom_read=0

include userconfig.txt

hdmi_group=2
hdmi_mode=87
hdmi_timings=400 0 100 10 140 1280 10 20 20 2 0 0 0 60 0 43000000 3

userconfig.txt

Add your custom config.txt options to this file, which will be preserved during updates

Touch Display rotation setting below: do not alter

display_lcd_rotate=3
display_hdmi_rotate=3

Are you on a fresh Volumio installation now?

Config files look good.

Please check if the display blanks as expected if rotation is set to 0 deg.

I haven’t started over yet. I’m hoping I don’t have to. Took me a while to get up and running. I will try rotating to zero.

If that should make no difference you may also try adding

hdmi_blanking=1

to “/boot/userconfig.txt”. IIRC I have seen posts regarding Waveshare displays where it was stated that this setting was needed for the Touch Display plugin’s screensaver to work.

adding the hdmi blanking did the trick! thank you so much for the help