can't create/find a music library

Hi all–

I have a brand new installation of Volumio Beta 1.1 on an R Pi Model B. It’s unclear to me how to create and populate a music library from within the Volumio UI. So far, I’ve had two problems.

First, I’ve been completely unsuccessful mounting the NAS disk where most of my music files live. I consistently receive the error message: Last system mount error mount: cannot mount block device //192.168.1.1/My_Passport/music/ read-only . I have tried changing the mount command to RW, and changing the NAS permissions to RO, neither of which has any effect. Since this is where my music collection resides, it’s very frustrating. Here are my settings:

Source name RadioMike
fileshare protocol SMB/CFIS
IP address 192.168.1.1
Remote directory /My_Passport/music/
Username Admin
Password xxxxxxxxxx

The NAS is accessible by other computers on my network just fine, including another small linux machine. I’ve been up and down the configuration choices in Volumio and can’t find any combination that will mount my NAS.

The second problem is that I tried to circumvent the NAS problem by plugging a portable USB drive directly into the R Pi, and Volumio doesn’t seem to see that drive, either. At least, when I click Update MPD Database (I’m guessing here, because I haven’t found any documentation yet), wait a while, then click Browse and USB, there is nothing displayed other than a blank page with a Back icon, so I’m assuming that Volumio is not mounting the USB drive? Or something else?

So far the ONLY sound I’ve been able to achieve is via web radio, which works well. But I want to access my music collection! Any advice would be appreciated.

Best,
–Mike C.

First self reply, LOL. Oddly, after a restart Volumio found the USB drive, and is currently updating the MPD database. Although the NAS is preferable, a local copy on the R Pi would be workable in a pinch. It’s playing now, and sounds good even without the DAC, right through the headphone jack. XBMC crackled and popped!

So now the only problem seems to be mounting that NAS drive.

Best,
–Mike C.

I’ve been reading through the forum this afternoon and apparently the NAS problem is widespread. Unfortunately, I haven’t been able to find any consistent solutions yet. Do I need to install another package? I’ve verified that /mnt/NAS exists.

My NAS is located at 192.168.1.1/My_passport/music. What am I missing here? I’m currently reinstalling cifs-utils.

Ah-ha! Now the error mesg has changed to “mount error(22): Invalid argument Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) .”

Best,
–Mike C.

More self replies, to document what I’m doing. I’ve finally mounted my NAS with this:

sudo mount.cifs //192.168.1.1/My_Passport/music /mnt/NAS -o user=guest,sec=ntlm
Password: [my_root_pw]

It’s late though, and I’ll probably wait until morning to figure out whether Volumio can see the library or not.

I’ve been playing the local copy of the NAS library via USB all night. Volumio is a nice piece of work! Thank you for making it available.

Let us know if this works out.
I’m having similar problems - I’m using a Sony Media Server (which is essentially a NAS with DLNA capability) I’ve tried using the IP address (192.168.1.105) along with the mount (/Sony_Server/Music) as well as try the SMB address (SMB://Sony_Server/Music) and I still cannot view it in Volumio.

USB works fine with FLAC and MP3.

Any help or advice would greatly appreciated.

Don’t place / in the share name. Try with Just sony/Music, or just music .
Mind that these are case sensitive!

Had the same problems.
I googled my ass off and found this:
I did a fresh install on the sdcard.
ssh into the, in my case , raspberry.
sudo mount -o uid=pi,gid=pi /dev/sda1 /mnt/USB
Then pointed the browser to the volumio and went into the GUI
Library --> update .
USB popped up under the browse option, and the raspberry started reading and updating the dbase.

Did a few reboots, power downs, no more problems playing from USB Harddisk.

Have to correct myself, usbhardrive is not auto mounting, giving a sudo mount -o uid=pi,gid=pi /dev/sda1 /mnt/USB , and back is the USB HD.
Anyone who knows how to get the auto mount working

Did you get it working?
I have the same problem, and have tried everything that I could find but no joy.

Is there no support on this software anymore?