Can't connect to WiFi, hotspot restarts after attempt

I have been trying to connect volumio on my Raspberry Pi 2 to WiFi.
I can connect to the hotspot, I can connect to ethernet, I can see all nearby networks, and I have used the same pi and WiFi dongle multiple times before with multiple different networks including the ones I have tried connecting to right now, but I can’t seem to get it to work on volumio.

I have tried editing /etc/network/interfaces manually, which I know is not recommended but I couldn’t think of another way, but that did not work either. I have also tried a clean install.

Whenever I try to connect to my home network via the web interface the hotspot briefly turns off and then immediately turns on again, whenever I try to connect to my mobile hotspot the web interface shows a loading icon for a while, returns to the home screen and then nothing has happened.

At random times the hotspot, wireless networking, or both will be set to off. Changing the setting to on does not work, but the settings will turn on randomly again as well.