Can't connect my SAMBA shares hosted by onother Raspberry


I have two Raspberry Pi’s. One of these has my external USB HDD connected and samba server running on it. It let everyone in the house connect to it and browse content of the hard drive.

I wanted to use my second Raspberry Pi as a music player connected to the home network and Cambridge Audio DAC magic. Unfortunatelly I can’t mount the samba shares provided by the first raspberry on another one. I think I have reed all avaiable subjects on this and other (samba / linux in general) forums.

Depending on what i try i get different errors:

Retrying with upper case share name mount error(6): No such device or address Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)


mount error(22): Invalid argument Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I tried mounting this shares both using webpage and terminal via SSH.

I updated and upgraded all packages and I run latest Volumio 1.4 downloaded today from Volumio webpage.

If you have any idea how can I make Volumio use this HDD content please post it here.

PS: I can easly acces this HDD both from my Android devices and Windows PCs



  1. A “Remote directory” that contains music can NOT have any spaces in its name because it causes mount operation to fail.
  2. The only mount flags that I have used are sec=ntlm

And it works even after reboots and power outs ^^