Can't change the volume


I have a fully fonctionnal and playing Volumio on my Pi, with a connected NAS and a perfect connexion to Podcast and webradio.
Unfortunately I can’t change the Volume anymore (it did work). I have cehcked all parameters and then rebuild the system from scratch (new volumio image etc…) without installing anything but the image (no plugin). Still not adapting the volume when moving the “button” on the web interface.

Any idea?


Volumio Information

Volumio Version: v2.907
Hardware: RAspberry Pi 4
DAC: Audiophonics ES9023

Just to say.
I have seen some related topics on the forum but none of the solution is working (mainly “update top latest version, we fixed it”)

Your Dac based on ess9023 does not support HW volume control. You have to use a software volume control.

Hi Balbuze,
Thx for your answer.
I don’t understand. I have no HW volume. I use the webinterface to change the volume and it did work once.
What do you exactly mean by “you have to use a SW volume control”?

A HW volume control on a Dac is not a physical button. This how the volume level is handled inside the Dac… Some chip provides it and you can select it in Volumio. This is the best way to set volume. But in your case, you have to choose software volume in Volumio in order to set volume.
In both cases, you use the web interface :wink:

ok thx for the explanation.
I have set the parameter to “Software” in the volume mixing options. Doesn’t work. I will continue to investigate

Ok found the solution. A quick search on the web with your input. I was working woth the ES9028 set up in the I2S. I changed it to HIFIBerry DAC setting. Volume works. Good.
Thx a lot for your help.