can't change password back to default

I changed the password (using the passwd command) but now want to change it back to the default but Linux says “Bad: new password is too simple”. I think it must be at least 6 characters, contain at least 1 upper & lower case letter & 1 digit. The default Volumio password is therefore a problematic choice. How do I now change it back? And will this cause other problems if I don’t change it? Am using RPi3B with latest 2.362 Volumio image.

Try deleting user data from the system settings.

Changing the user password is a desirable thing, but unfortunately not yet supported by Volumio. Things like plugin installations will fail without the default password.

Thanks @chsim1. I Deleted User Data. Of course this meant an hour setting up the RPi again with all settings & plugins. I had noticed the Wifi & wired network connections were very slow when connecting from PC. Now the password is reset to default the connections are fast again. There should be a BIG warning NEVER to change the Volumio password as this causes so many problems. BTW I only changed the password because another user suggested this may fix the autoplay plugin. It did not.

An easier way is

sudo passwd username

This bypasses the password quality check.

Ah, nice call … one to remember :wink:. Sorry about your lost hour Andrew.

Just ran into the same issue. Workaround is though, to do installations, and once configured, change the password. Reverting is doable as prof mentions with sudo.

However, it is 2021 now, so I would suggest to Michelangelo to pick this one up, since it is a real thread to be honest.

Cheers