Can't boot volumio 1.4 on Cubox-i

I just got my Cubox-i 2. I copied the new Volumio 1.4 image to an 8 GB flash, and when I boot, I get the boot prompt, followed by a series of colored lines filling the screen.

Clearly, something went wrong.

Any ideas?

Followup info -

I’m able to boot GeexBox just fine. I also re-downloaded and reimaged the volumio 1.4 image on a different SD card, with the same results.

I have the same problem: my Cubx-i2 can’t boot Volumio 1.4.
Is Volumio made only for Cubox-i4Pro??
Is it possibile to make it work on a i2?

Update: Got a faster (class 10) 8 GB Micro SD card, and now the Cubox-i fails to load the kernel image:

** File not found boot.scr **
** Unrecognized filesystem type**
112 bytes read in 120 ms (0 Bytes/s)
Importing environment from mmc0…
4108472 bytes read in 234 ms (16.7 MiB/s)
booting from mmc…
Booting kernel from Legacy Image at 108000000…
Name: Linux 3.0.35
Type: ARM Linux Kernel Image (uncompressed)
Size: 4108408 Bytes -= 3.9 MiB
Load Address: 10008000
Entry Point: 10008000
Verifying Checksum… Bad Data CRC

Error: Can’t get kernel image!

I installed the image 1.4 on two cubox-i (i4Pro) versions and it works fine!

I flashed the image with diskutils (like described in the download section of

Hm. Has anybody had success with the cubox-i2 (the i4pro seems to work, apparently)?


Don’t bother trying to run Volumio 1.4 on Cubox i1 or i2, they have slightly different hardware that make them incompatible with the kernel built for Cubox-i4 packaged in this release.

I have managed to run 1.4 on my Cubox-i1 by updating it to the latest 3.10 kernel, however it is not straightforward. I will try to post the image if I can figure out how to reset all the settings.

In the meantime, you can use this Volumio 1.2 image with an updated kernel which worked for me (except for the USB DAC that needs a bit more work): solved-wifi-cubox-t1117.html


OK try this out: … 024.tar.gz

Please note that Airplay is configured to output on hw2:0, if you use the Cubox HDMI or SPDIF out, it will not work.
You need to edit /etc/init.d/shairport and change it according to your environment (try “sudo aplay -l” to get the correct hardware id)

Your updated image works a treat!

It boots insanely fast, too - was somewhat disturbed to see the HDMI output turn off, but it’s available via the web page now.

Boots & is indexing my insanely large collection as we speak!

I updated the shairport to point to the S/PDIF output (as desired).

I can boot on a Cubox-i2, but can’t get the database update to complete. I think it gets stuck on the same files, not sure yet. I can go back to 1.2 so I’m not completely stuck.

Any ideas why some files will cause the database build to hang ?, or rather take down Volumio ?

disable ffmpeg in mpd.conf

Hi M1024 !

Yes, your image works, thank you ! …though not completely… but that is perhaps due to the original 1.4 image.
I also run the cubox-i2 and I got everything working with the 1.2 image except being able to use my USB DAC
witch did not make me too happy… well let’s return to current image.

These remarks are directed to Michelangelo or anyone who think they have the answer.

  1. Why not make it clear that the original release of the image only applies to Cubox-i4 ?
    (If I had known I would have bought the Cubox-i4, I just thought it was overkill)

  2. I can’t make the WiFi work (This worked like charm with the tweaked 1.2 image)

  3. The mounting of the NAS is complaining "mount.nfs: mount point /mnt/NAS/Music does not exist ", this has never happened
    before and I was dead sure about the settings. Well i tried to do an “Update MPD database” anyway, and it worked and playes music !?
    After rebooting I get a green checkbox for the NAS mount.

  4. The WEB-interface was really fast before and I just loved it. Now it is very slow clicking on NAS, just hangs and I have to wait…
    after that is seems normal again going down in the file tree.

(( Phi

I’m recompiling Cubox-i kernel. So it will have wi-fi support, and it will be compatible with the entire cubox-i family (and Hb-1).
OTA 10 days…

Michelangelo, thank you for a very positive answer. Really looking forward to this.

(( Phi

Will the new image fix optical out? I tried the update image from the link above but I don’t get any sound from the optical output.
I have the Cubox-I4 as well.

Yes, it will.

this is awesome news :slight_smile:

Great to hear! I was mistakingly stating that I had the I4 but it’s actually an I2. Is shouldn’t matter I guess, since you’re going to support the whole I1-4 range anway.

I have the same problem on my Cubox-i2U using version 1.4 (both with original 1.4 kernel and newer posted in thread solved-wifi-cubox-t1117-10.html#p5495).

After a few minutes, the cubox-i hangs and cannot be connected to anymore (http or ssh).

I tried to change the ffmpeg enabled segement to “no” in mpd.conf, but that did nothing.

Hey all, new here.

I think I’m in a similar situation and I suppose just waiting until the new kernel is updated. Have just bought a Cubox-i4, can get the latest firmware running fine but no WiFi (which I need for my setup) and the 1.2 doesn’t support Airplay which is also super useful. Any update on the status of the new software?

BTW, I tested this system out using a Beaglebone black into my new Devialet 120 yesterday and worked a treat! picked up the USB interface (Devialet use an XMOS device so I’m guessing most other XMOS based USB DACs will work too). Sounded incredible! and such a neat little solution.

Most looking forward to getting this all up and running! Thank you all so much for all the hard work that’s already gone into this!