Can't access player via normal home wifi

I installed volumio on my Raspberry Pi/Hifiberry Dac Pro+, and it seems to work well. However, getting control of it isn’t working like I think it should.

On initial setup (connected via ethernet cable to my router) I switched off the hotspot options. Connected to my in house wifi. Unplugged the ethernet cable, attach to stereo (and a ssd drive). Try to access the unit via normal wifi - no go. I see a new volumio hot spot, so I connect to it, and it works great. I think “that’s odd, with hotspot turned off, I have a hotspot. Maybe if i turn hotpot back on, I can access it via normal wifi”. So I do so, and can’t connect at all. So I repeat the set up I did originally, turn off hotspot, and it’s back to working, but only if I log out of my normal wifi and internet and into the volumio hotspot. (edit: there may be some mistake in this paragraph - my memory may be doing tricks. I’m pretty sure the hotspot on/off settings are actually working the way they should be)

So how can I set this up so I can access the player via my normal wifi? I.E. have volumio running in a tab, and be able to do other internet type stuff at the same time? Surely there’s a way to do this.

Edit: I should add that it’s a raspberry pi 3B, and I’ve installed whatever the newest version of volumio that was available as of 3 days ago. And I’m trying to access it with a macbook pro and/or my iphone and ipad, none of which can connect (except via the volumio hotspot), even though fing is showing it at And it’s a AT&T Uverse router based wifi network.

Arggg, this is making me nuts. I’ve tried every combination of settings, still can’t access the player via wifi. Any ideas? Please? This is a deal breaker. Should i go back to runeaudio (which didn’t work in different ways)?

Are you using an open network (no security)?

you may want to check this about known HW issue between Pi3 and Hifiberry Dac Pro+: there might be some specific wifi channels to check & avoid.
Or try wifi connectivity with DAC unplugged to check if you get reliable wifi and exclude this potential issue.

Thanks for the responses, and sorry for the late response. I eventually reinstalled runeaudio, which seems to work fine now, unlike my first experience with it, so I guess I’m good for the moment.