Cannot mount my Synology NAS in Volumio

OK, I have been trying to mount my Synology NAS Music Library for about 3 days now… Have searched the internet and read all of the other people’s problems trying to do the same thing… Applied all of the given solutions to no avail… I have no trouble accessing my Music Library with PiCorePlayer, but I cannot get Volumio to see my Music Library on my NAS… I get this error when trying to Save the Folder on my NAS.

Any ideas…


That error says that the server is denying access: have you set up the appropriate NFS permissions on your NAS?

Yes, I have followed a tutorial I have found on Volumio for adding the NAS.
I have many other software Apps that have no trouble accessing my NAS, including other music Players.
I never had to add any ‘extra’ permissions for them either.

Here are my settings.

Synology Permissions.jpg

What exactly do you mean by this, and where was the error message shown reported? Have you added your NAS drive and folder in Volumio?

Sorry, I should have said “I got this error when trying to Save the Music Folder on my NAS in Volumio, when trying to add the Music Folder in Volumio.”

The Error message appears when trying to save the NAS Credentials in “Add new Drive” in Volumio.

Could you try running ‘sudo showmount -e’ on your device, so we can see what folders Volumio can see on your NAS?

Thanks for the reply. By ‘device’, I assume you mean the Raspberry Pi that I am trying to run Volumio on? – If so, where can I input this command?

Sorry, I should have asked if you can ssh into the RPi, and then issue the command at the prompt after logging in. If you don’t know how to ssh, then we’ll have to have another think.

Yeah, not a linux guy, here… I’m a Cobolasaurus from the 70s…

I think we’re just guessing here then without more info from the device. Firstly double check all your path names etc. that you entered when trying to add the drive.

Secondly, reboot, and try again to add your NAS drive. After you have received the error message, then send us a log. I doubt that this will contain any more information, but it’s worth just checking.

After that, I think you either need to learn how to ssh into the RPi, or attach a monitor and keyboard. This will give us more options for trouble-shooting.

Like the Myriads of others on the internet whose postings I have been reading over the last 4 days, it 'magically ’ added my NAS… I did nothing different, except re-boot the RPi a few times when I was trying to get the Logs to Send (BTW-- this didn’t work either - As the message of Sending the log report never finished — this is what made me keep re-starting the Rpi).

This software is buggy as there are countless others that have described this same problem… Obviously my syntax was correct, as you noted in the first post that my NAS did not have the ‘correct’ permissions… I have not touched the NAS today!

Thanks for your help on this and I would suggest to the developers to make the Network Drive adding more robust.

Log Report.jpg

Well, all software has bugs, and yes they need fixing. I would argue with your conclusion that “myriads” of people are having problems adding their NAS, and can I say that from my experience it is often the user not setting up or understanding their NAS properly that causes the problems. Volumio has attempted to simplify this process by automatically attempting to discover NASs, but this is problematical, and can fail.

Volumio is a small project that relies heavily on feedback from it’s Community to improve the software and user experience. Feel free to contribute, and make things better for all of us.

Anyway, glad that you got things sorted, even if it was “magically” :wink:

@chsims1 been having probably the same issue with connecting my synology ds918+ to volumio.

I ssh’d into my raspberry pi and applied the command you suggested to my locally connected raspberry pi (sudo showmount -e and received this response:

clnt_create: RPC: Program not registered

Also, when I attempt to setup the NAS through the Volumio UI and click on Save, I receive the error popup message in orange.

I’m setup on headless running sudo commands through my mac’s terminal.

I can also see the raspberry pi folders I’ve created and can drag and drop files into the folders “Internal folders” and “USB”, but can’t write to the “NAS/audio” folder. This is the folder I’m trying to write too. I’m also unable to connect to the raspberry pi as the volumio user and remains logged in as guest.

Let me know what other info I may provide to get me on the right path in getting volumio to connect to my NAS.

Screen Shot 2018-11-11 at 10.24.35 AM.png
Image 11-10-18 at 9.35 AM.jpg

Ssh into your RPi and type ‘sudo systemctl status nfs*’ please.

Edit: you said you tried showmount -e, but then your error message refers to address What is the correct IP address of your NAS? is my pi’s ip and the is my NAS’s ip

I ran sudo systemctl status nfs*, what am I looking for?


this is the output when I run the shadowmount command:

Export list for
/volume1/iTunes itunesmedia

this is the output when i run the nfs* command:

[code]● nfs-common.service - LSB: NFS support files common to client and server
Loaded: loaded (/etc/init.d/nfs-common)
Active: active (running) since Mon 2018-11-12 07:38:41 UTC; 3 days ago
Process: 509 ExecStart=/etc/init.d/nfs-common start (code=exited, status=0/SUCCESS)
CGroup: /system.slice/nfs-common.service
├─515 /sbin/rpc.statd
└─527 /usr/sbin/rpc.idmapd

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.[/code]

So it appears that you have not given permissions to your RPi to access your NAS … have a read here … vilege_nfs

I had a very similar issue with mounting shared from my Synology on any of the Volumio players around the house.

The solution took awhile to figure out, as all the permissions were correct and I could mount the shared from other Linux, OSX and Windows machines no problem.

Go into My Music and down to the Add Network Drive section of the GUI on your Volumio installation.

Select your NAS from the list of network devices

Enter your proper path if it didn’t detect it, etc…


Enter your login name and password for the share

And here’s the most important missing part…

In the OPTIONS field, enter:

Save and voila, mounted successfully. :slight_smile:

Hope that helps someone!
Take care.

I followed your steps, but:

with NFS I get the following error:

Error in adding network drive
exec error Error: Command failed: /usr/bin/sudo /bin/mount -t nfs -o ro,soft,noauto,‘ver=1.0’ ‘r2d2:/Volume1/Music’ ‘/mnt/NAS/R2D2’ mount.nfs: an incorrect mount option was specified

with CIFS I get the folowing error:

Error in adding network drive
(22): Invalid argument Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)