Cannot get two Pi's to start Volumio Local

I have checked the previous help requests and the Internet to try and resolve what seems to be a basic problem. I have a windows 7 PC and two Raspberry Pi’s, both of which have HiFi Berry DACs plugged in. One Pi is an early model which needed to have additional pins soldered on the board to connect the DAC. The second is a brand new model 3 with a DAC +. I have been trying Kodi for playing files but want to have a headless solution for music. Volumio looks to be a good solution for this and the Pi is a small device so, in theory, a perfect combination.
I have produced the SD card images and started the Pi’s as instructed. If I check on my PC/Computer/Network I can see that a device called Volumio is on the network. I have tried both Pi’s alternately and they are both there when powered up.
My problem is that I cannot get Volumio.Local to work. The command in my browser produces “page not found”. I have tried loading Bonjour as instructed and rebooted the PC and the Pi’s. Bonjour says it is an Apple printer utility but it does see other devices on my network, such as my Synology NAS which works fine with Kodi.
I want to use an Android tablet or Phone to actually command the Volumio device. Should I be using the Volumio Local command on them to configure the system.? Everything is on the same network, One router and a couple of switches. The PC and each Pi as I test them are plugged into the same switch using cables not wireless. I have not plugged a keyboard, mouse or screen on the Pi’s as the instructions say this headless device is also headless configuration.
I appreciate that this is a product produced and supported by a small team of enthusiasts, not a commercial organisation but bot the Volumio website and HiFi berry suggest that this is simply plug and play. Based on the number of similar problems I have seen on the web it looks like some better instructions are needed to get over this initial configuration issue. Whilst I have an electronics background it is a long time since I used command line instructions and do not want to become a programmer. Can anyone help or guide me please. When I was an engineer the standard response was RTFM (read the F**** manual). I have tried to help myself using the site information but am overwealmed by the problem at this stage.
I would be grateful for any assistance and will supply any information requested. Volumio versions are 2.041 and 2.018

Hi Andrew,
I never use the volumio.local route with the rpi that I have running Volumio. Just use the ip address of the pi in the search bar of whatever device you want to connect through; windows pc, tablet, phone.
Hope that helps with initial connection.

Using IP address successfully got me into the Volumio config screen. Thanks for the help.