Cannot connect to volumio.local after installation

Hi,

hope this forum can help me. I am a complete noob trying to make this work but unfortunately following the instructions does not yield any result.

I purchased a Raspberry Pi because I wanted to stream music to my hifi system (I am currently using a DAC to connect the amp to my laptop)

System
Laptop: Windows 7
Raspberry Pi 3 Model B
Volumio version 2.0

I follow the steps of the installation guide.

  1. I format the SD card I will be using
  2. I save the volmio image on the SD card using Win32DiskImager
  3. I connect my raspberry pi to a keyboard and my monitor, insert the SD card and then plug in the charger. At this stage I do NOT the RP to my DAC yet.
  4. The installation starts, an error message is displayed
    "… brcmfmac: brcmf_add_if: ERROR: netdev:wlan0 already exists
    this error is repeated with alternating "ignore IF event messages
  5. I press enter and get to the login. I login to volumio using volumio/volumio
  6. I am trying to connect to volumio by entering volumio.local on my laptop. It doesn’t work.
  7. based on what I read, I check ifconfig to look for the IP address.
    It displays eth0, lo and wlan0. I try to type in the IP address displayed there in the wlan0 paragraph (first I tried the entry under inet address, then the entry under Bcast). Both of them did not work

I do see volumio in the list of networks on my laptop. I can actually connect to it using the password volumio2. I am not sure what the purpose of that is. But it shows that the volumio is actually “alive”

As a next step, I tried to connect the RP to an ethernet cable. Just to see. I have no ethernet cable next to my hifi system, so this is not an option, and part of the reason why I bought the more expensive RP model with inbuilt wifi.

I resetart the RP again and repeat the steps 4-6 again (but instead of the IP address under wifi, I go for the one under eth0). again, can’t connect.

Instead of my laptop, I try accessing volumio via my phone (nexus 5s with latest android version 7.1.1). Again, nothing works.

Can someone help? thanks.

Did you see an IP address after ifconfig?

Did you try inputting that IP address into the browser instead of volumio.local?

Unless you use a apple device, you have to enter the ip adress to connect your device android). In Linux, you can use volumio.local. In windows, you may need to install bonjour as service or using as well ip adress.

Hi,

yes I did use the IP address I found in ifconfig, on both my laptop (windwos) and phone (android). no response.

I also downloaded bonjour. I was confused because it is about printers. But it said it couldn’t find any printers nearby.

At first boot, volumio will create a wifi hotspot. You have to conect to it if you have no ethernet cable, and configure volumio (wifi password). Then the wifi will restart, and this time you should be able to connect to the ip adress you 'll find with tools such as ‘fing’ on android.
But device are to be on the same network / subnet. Is it your case ?

Thanks for your explanation. How do I connect to the wifi hotspot?

I saw the volumio hotspot in my list of available networks but couldn’t access it. which password do I use? I tried “volumio” but it didn’t work

use “volumio2” See volumio.github.io/docs/User_Man … Guide.html

Note to developers - this should probably be added to the instructions on the Download page (probably under “Connect To It”)

To connect to Volumio from a Windows 7 PC browser, try

http://volumio

No need to install bonjour service.
Hope this helps.

Hi,

thank you all for your help, it now works.

just in case someone faces the same issues, here is a summary of what I did after the installation

  • waited for volumio to create a hotspot (called “volumio”, connected to it with my devices using the password “volumio2”

in volumio, entered ifconfig and looked for the IP address next to i-net address. Part of the problem was that the IP had changed so I kept typing in the wrong IP address.