Cannot connect to Synology DS


Very Newby from Germany. As Synology no longer supports Logitech Media Server, I looked for a solution because there a several musicplayer as Squeezboxradio etc.

So I got me a raspberry PI 4 (4 GB) and suceeded in installing volumio.
After that I installed the plug-in logitech media server.

After long during trials to set my DiskStation as “Source”, I found out that the players find my music files. But not the way I intended. It is very uncomfortable and a lot of klicks to get there and back to “radio”-music.

I did everything to mount an NFS Share like descriped in the help doc. Even try some options etc.
But nothing works.

Maybe it’s the IP Path

Strange thing is the slash between IP and Path??? How come?

In the “media servers” the DS Drive visible, and can be opend.

But at musiclibrary the drive is also visible, but empty.

Hope you can help me in this case.

Volumio asked you for an IP, not the full unc.
Try this:
NAS IP Address:
Path: volume1/music

Thank you, but I tried this already.

See here what I filled in:

This is the result after that

The error message disappears after a short time :face_with_hand_over_mouth:

Despite following the setup guide, I suspect this is a problem with your NFS settings on your NAS. Can you do some screen shots of your settings please?

Also, if you are able to ssh in to your RPi:

How to enable and use ssh.

can you paste the result here of typing the command:

sudo showmount -e

Lastly, please try entering the IP address as when you try and add a drive in the Volumio UI.

you still add https in front of the IP. Only enter the IP like

1 Like

You seem to be chopping and changing between cifs and nfs (from the screen shots). Please stick to one or the other, or you are just making problem-solving more complicated.

Haven`t found the time to check your solutions. Maybe in the evining - still working.

The chopping happens - don’t know why :face_with_monocle:

I write and nfs, and after saving it changes into what you see on the screenshot.

On my DS I made these settings

Here’s how I solved my NAS mount issue:

HTH, Dave


Made everything like you told, and first it seems to work. But the I get an error message.

Unfortunatly to fast away. It’s something like (even it’s in german): No such file or directory, refer to the mount.cif, look for the manual (ha,ha)

Strange: Made the path like volume1/music

After that it changes to volume1/music_1

I’m totally confused now about whether you are trying to mount a cifs or a nfs share. The mechanisms for these two are both very different, and they both have different requirements.

Your first screenshot shows you trying to mount a cifs share.

The second screenshot show you trying to mount a nfs share.

Your last post quotes an error about a cifs share.

I’ll let someone else try and follow your thread ;).

let’s start from scratch. You’re switching between CIFS and NFS and wonder why it is not working.
Please answer the following questions. Without it I can’t support you.

  • Which protocol did you enabled on your NAS, CIFS and/or NFS?
  • If CIFS, which SMB version is supported by your NAS (V1 and/or V2 and/or V3)?
  • Which user has been setup on your NAS to access this share (alexmusic?)
  • Is this user setup for NFS or CIFS or Both?
  • What is the path of this share, as normally the “volume1” should not be part of this, Please validate the exact path from a windows machine. it’s either \\music or \\volume1\music

I can clarify one point … in Synology NASs the NFS shares are located at ‘/volume1/sharename’, but it would just be ‘sharename’ with cifs.

@ chsims1

That did the trick - now system is idexing the files. That may take serveral time caus there are about 650 MB music files :roll_eyes:


Thank you for your help! If the thing is now working, everything is OK.

Anyway. I found out that the Logitech Media Server on Rpi is just half the solution for my problem with the squeezebox devices.
If I switch to “library volumio” I may hear my stored music. But it’s not possible to listen to Internet radio stations with the devices.
As I told in my first post, I’d like to substitute my LT Media Server on the NAS because it’s not longer supported by Synology.

Sorry. Take it all back. Even radio function with preset buttons on my squeezebox radio is working. Now after indexing was finished, I found everything as used to.

So wonderful!!!

Thanks to everyone who tried to help me :star_struck: :clap: :clap: