Cannot connect to share on Win 10 - help pls!!

This problem is driving me nuts…
On my Win 10 machine I have a second disk that windows ID is ‘k’ and my music is located: k:\Music
In volumio, when I add a new share, it sees the windows machine (well, about one in 5 tries it finds the machine!!) and I fill in the appropriate fields:
alias: MyMusic
file share type: cifs
username, pw, options are all empty ( username is jjj, I do not have a user password on my Windoz 10 machine where the music is located - and I really don’t want to have one)

I hit ‘Save’ and I get a popup: Network Drive Authentication
This drive requires password.

How can I get volumio to connect to my windoz share? I have tried a bunch of things such as: not using Alias, entering jjj as user name, leaving pw blank, user jjj and for pw put a space, user jjj and pw as random string, tried option version=1.0, Version=1.0, version=1 with lots of different combinations of these fields, all with no luck, rebooted both w10 and rbpi, rebooted routers/switches, etc. Nothing works…this is ridiculous…
Any help is really appreciated…

Just making sure you would use the format “vers=n.m”, not “version=n.m”
I don’t think smb version is the issue though, in that case you would get a different sort of error message.
This is about authorisation, make sure the share is published properly, then you should actually be able to browse the network when adding a new drive…

You are correct about the “vers”…i mistyped the post in my hasty/frustrated situation, but I did use ‘vers’

You make a good point about properly configuring the share on Windoz. I thought I did it correctly. I can see the windows share on other windows machines on the same network. But the really confounding part is the volumio error message about user name and PW. Does Volumio networking require them? (I would think not ).
I have basically configured the windows share as open to everyone, everyone has r-w-x privileged, with no authentication required.

Can you point me to some guidance about how to do it so it make Volumio happy? (Can I do something in Volumio to get around this issue?)

Or suggest a way to ‘look at’ the network share with some tool to see if it is configured correctly? I sun some Ubuntu servers on the same network and have smb installed.
Thank you.

I had a similar problem.
I believe it is an incompatibility caused because either Win 10 does not automatically install SMB version 1, or because Volumio etc doesn’t like SMB version 3, at least on my system.
My workaround was to forcibly install SMB version 1 client on windows. Not sure if this has any other implications for security and so on, but it did work.
At your own risk obviously. Perhaps SMB 3 compatibility is something the awesome developers might want to look into further. :slight_smile:

It’s hazy now, but the general method was
Control Panel
Programs and Features
Turn Windows features on or off

Expand the SMB 1.0/CIFS File Sharing Support option.
Check only the SMB 1.0/CIFS Client option.

Hope it works for you, it fixed mine.

Make sure that guest access is enabled in the Windows share! The share might not allow guest access or access without a password.
(from your opening post I deduct at least that your accessing it as a guest, since you say username etc. is empty).