Cannot connect to a hidden wireless network

The title says it all.o connect to my network via

Able to connect to my network via a wired connection and I can connect to the wireless hot spot, but no joy getting Volumio to connect to my hidden network.

Tried turning off the hot spot. This also turns off wireless networking. If I try just turning wireless networking back on, its back off again when I refresh the page. The only way to make it stay on is to turn the hot spot on.

When I choose a manual connection, check hidden, type the name of the network, and connect, the page goes away and when it comes back I’m not connected to the wireless network and nothing has changed.

Is this functionality currently broken or am I doing something wrong?

It’s not clear to me what you are doing and in what order. Also, what version of Volumio are you using?

Would you mind posting a step by step list of what you do and what does not work as you expect. We can then try and replicate it.

VERSION: 2.041

Go to settings and click on NETWORK

Under “Wireless Network” go to “manual WiFi Connection” and click “connect”

Check box “hidden”, leave security at “open”, type in network name, and click “connect”

Goes to spinning circles disconnect screen for a few seconds and then back to main screen.

Go back to settings and then NETWORK.

No connection has been established. Still on hot spot.

Also tried this process while connected to Ethernet. Same result

Also tried turning off the hot spot. The wireless networking stays off and trying to connect to my hidden network still has the same result.

Are you on a wired connection or hotspot at this point? (remember, I’m trying to reproduce your problem :wink:)

Edit: assuming hot spot.

The first time I tried this, my security was WPA2, and everything worked fine … wifi restarted and it got an IP address from the server on my network. I then thought that I should double-check your exact scenario ie. use an ‘open network,’ and I was surprised to find that you are indeed correct. A network connection is not established if the security is set to ‘open.’ Please report this as a bug on Github (

In the meantime, set up your network with WPA2 unless you have some particularly pressing reason not to do so.

I like just using a hidden network with no other security. I’m not sure how secure this option actually is, but I have been doing it for about 10 years and have yet to find a MAC address logged into my router that wasn’t one of mine.

Thanks for testing and determining that this was a bug and not just user error.