Cannot boot Volumio 2.773 on Tinkerboard S

I am running Volumio on an rPi 4 successfully, but wanted to see if I could get better performance on WiFi and bootup with a Tinker board S. The board boots TinkerOS successfully from the eMMC and SD card, but I cannot get the Volumio image to boot. The red led comes on, and then the green led starts blinking rapidly, while the yellow led led blinks twice every second or so. This continues basically forever with no activity on the HDMI display.
When I try to install it on the eMMC card, the red light comes on, the green light blinks briefly and then the yellow light blinks twice and then pauses, repeating over and over. The HDMI screen seems to get a signal briefly, but nothing comes on. Then it appears to shutdown and tries to boot up again. This seems to continue in perpetuity as well.

Has anyone tried installing this latest build on a Tinkerboard S? Is there a different image for the Tinkerboard vs Tinkerboard S? It looks like a bad image. Both the eMMC storage and SD card are fine, I’ve put TinkerOS on the eMMC and SD card after failing with Volumio, and they come up perfectly.

I looked at the Volumio build repo in Github, thinking that maybe I could launch a build from source and see how that turned out when it completed, but I don’t see a build specific target for the Tinkerboard. I also tried to find an older builds, but had no luck with directory listings or guessing reasonable filenames.

Any help would be appreciated!

Just an update - I found a link to an older image ( v2.527) in the ChangeLog and tried that. That image gets as far in the boot as the initramfs and then it stalls.
After looking through the source in the Build repo, I saw that the was just out of date, and there’s a tinkerboard target, so I managed to get the kernel image built last night. Going finish up the steps for building a bootable image later today. I would still appreciate any hints that anyone may have on what may be going wrong with the prebuilt 2.773 and 2.527 images.

I figured out the problem. In case anyone else has the same issue and searches for a fix, I’ll just leave a note here.

After trying to run a manually built image (fail), but successfully running Armbian and TinkerOS, I noticed that the keyboard and mouse were a source of occasional instability when doing the Volumio image build in TinkerOS.

The Tinkerboard S is really power hungry, and Volumio seems to be more demanding at bootup than either TinkerOS or Armbian. Even with a 2.4A USB power source, the Volumio image wouldn’t boot until I unplugged everything except the display. After I left everything else unplugged, it came up cleanly and I was able to connect to it’s hotspot and configure things. Plugging in a USB keyboard caused it it crash immediately.

I have an ultra wide monitor, and I wonder if driving the monitor is part of the issue? Now I understand why I read about people underclocking the Tinkerboard!