Cannot attach NAS

I’m having a lot of trouble attaching to my NAS.

The NAS is running Debian and Samba 3.6.6. A password is required to access it and it works fine when connected to from Windows.

I get one of two errors, depending upon how I set the remote directory option.

If I set:
I get:
mount: // is not a valid block device

If I set:
I get:
mount: Not a directory

Adding a trailing slash to either of these does not change anything.

I had very similar problems with raspyfi that I was trying to set up recently, I never got that working. Adding sec=ntlm does not change anything (nor should it actually, this version of Samba can deal with ntlm2)

Any help would be appreciated. I’m quite comfortable with Linux and can do whatever you like from the shell if that would help.

You should just create a samba share only on the folder you want to share, and add this one only. Like that:
IP : ip
Share: Music

Yes, that is exactly what I am doing.

In the ip field I have just In the folder field I have the path to my music folder from the root of the share. I have tried connecting to the root of the share with the same results. (ie just a space or a slash)

It should be then
Remote directory: share/folder

mind that it is case sensitive!

Yes. That is as I have it, exactly.

I have spent hours checking and rechecking.

I have copied and pasted the path to a login from Windows to be sure and it works fine.

Dont’t know, but maybe there is one “/” to much:
“mount: // is not a valid block device”

Try: “peter/Desktop/Media/Music”

Well I worked out what it was. You need the share name as part of the path. So in my case I needed to have:




Even though “Store” is really the share name (it doesn’t exist on the server, only in smb.conf), I should have known this, so sorry everyone.

DB is updating now.

Good! Let us know how it goes!

Just a little favour… Could you help the project by writing a little guide on how to use Shared Windows Folders with Volumio? That could be extremely useful !

I am no expert but I can try and describe what I have done to this point. Is this forum the best place for documentation at this time?

Yes, until I find the time to start writing a little wiki, we can make your thread as sticky…

I was able to work around the NAS SMB/CIFS issue by updating with

sudo apt-get update
sudo apt-get upgrade

However, I’m not sure yet if this was the best approach. Considering all the components that were updated as well.

I can now mount SMB shares, but not NFS mounts. I don’t think the GUI correctly constructs the mount command.

Would an apt-upgrade be necessary. I recall that wiping a lot of modifications.

I have success mounting various NAS’ by changing the mounting arguments and then a full reboot or started of the MPD daemon. Usually, its always a change with sec=ntlm or sec=ntlm2

I’m getting a similar problem, except that your solution does work out yet…

I have tryed all the combination suggest in this post and I still don’t get Volumio to see the NAS.

I’m getting the message : Last system mount error mount: Operation now in progress

Do you have a alternative way to test the connection.

Hi all,
Happy Christmas !
The new release named b1.1 wroks well with all my NAS. I’ve only one problem: the NAS Attach. I can’t see my DB update. Try all the workaround describer in this thread. The strange fact is that I can see my remote filesystem correctly mount with the command mount. Here you can see the command output:
/dev/root on / type ext4 (rw,noatime,nouser_xattr,errors=remount-ro,data=ordered)
devtmpfs on /dev type devtmpfs (rw,relatime,size=240208k,nr_inodes=60052,mode=755)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=49696k,mode=755)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=262144k)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
/dev/mmcblk0p1 on /boot type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro)
Ramdisk on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=262144k)
rpc_pipefs on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw,relatime)
// on /mnt/NAS/Music type cifs (ro,noatime,vers=1.0,sec=ntlmssp,cache=strict,domain=HOMEMUSIC,uid=0,noforceuid,gid=0,noforcegid,addr=,unix,posixpaths,serverino,acl,rsize=8048,wsize=8096,actimeo=1)

I can access all the files stored in the NAS browsing locally the /mnt/NAS/Music file system. Maybe there is a bug in Volumio update function.
Any Hints ?
Thanks in advance

Just an update about my previous post. I’ve changed the sec= parameter, try to set this one to sec=none (my NAS work with no security). No change in the mounting parameters, i can see ,sec=ntlm without any update.
Again thanks in advance

Find out the problem… as explain before, your share folder from Windows must be the complete path on your machine… I should have understand this quicker… it may seem obvious, but it is a bit different than a sharing under Windows. I hope this would help anyone stuck with this problems.

Simple trick to solve the problem. Copy the path on your windows share using a rigth click on your share folder address bar dans select copy address. It should give you something like the following: [b]

[/b]. In Volumio NAS, you must put exactly this [b]

[/b]. In text it meand the complete path, removing the C:.

The IP address must obviously be the IP of your share computer.

Thanks for this nice players!

I as well could not mount NFS shares through the Web-GUI, but it works when mounting it manually:

 sudo mount -t nfs -o proto=tcp,port=2049 /mnt/music 

or adding it to the /etc/fstab (for auto-mount at start): /mnt/music nfs auto 0 0

Also, the disturbances (pops/clicks/etc.) I had with the Samba shares are gone switching to NFS.

Hey guys!

Had lots of problems mounting my NAS shares, got error message saying that it was “read only” and stuff. I finally figured out how to fix it by adding sec=ntlmv2 at the end of “mount flag” option (under settings for NAS>advanced options>mount flag).
Might not be the same problem, but I thought I’d post it anyway. Might help someone :smiley:

office-supply-liberation.blogspo … nting.html

My first post (probably the last I do not speak English and I do not know linux).

Congratulations to those who have worked to achieve volumio.

I joined the forum to ask questions to solve a problem. Then I found the solution in the forum.

I solved the same problem for the hd connected to Technicolor MediaAccess TG788vn v2 (router fastweb).

Thanks Kaktusblad.

I made a quick screen capture tutorial of how I was able to get my NAS mount to work