Can SSH via ethernet or wifi, but no webui


I was playing around swapping between wifi and ethernet connections, and at some point during this process my pi has stopped serving the Volumio web UI

I can SSH into volumio as root either by using volumio.local or an IP address, but the web UI fails to respond if I try to access it via a browser.

Any ideas as to what I may have broken?

Happened to me as well today.
In order to debug the issue I tried to telnet to port 80 both locally from within the ssh session (got TCP response from HTTP server), and remotely (got no connection from my Windows box).
Note that both of the above should work.

From within the ssh session execute:

# telnet localhost 80

Then, when you get the connection prompt, just execute:


and hit RETURN

From the remote host specify the actual host name or IP address instead of localhost.

In the end I’ve re-written the SD card from scratch as the problem survived both reboots and unplug/plug-in cycles.

You can try as well to run a debug telnet session…

Happened again: no web ui but can ssh to volumio.
Tried running nmap from my web client, and port 80 looks open.

Discovered open port 80/tcp on

but no answer.

I would like to further investigate. Any idea?


try to restart mpd… Something could be broken with it

/etc/init.d/mpd restart

as you mention, restarting mpd works.
However, a reboot did not work before I put your suggestion in practice: I rebooted quite a few times and each time the webui did not respond (ssh worked instead).
Now, when I reboot it works.

So I think that either mpd was not started at boot (due to some other failure), or starting mpd failed for some reason at every boot.
How can I check that /etc/init.d/mpd restart was in fact called during boot? I mean: any log I can check that?
Where is /etc/init.d/mpd restart invoked from in the init scripts?

I’m wondering whether the issue might be related to any unclean/abrupt disconnection of the RPi: there being no UI apart from the webui, it might not be possible to know exactly when the RPi is actually off (yeah, all leds of the Rpi go off apart from the red power led, but I think that after all leds are off, still the RPi might be in the process of closing down) .