Boot failure since fresh installation of Volumio 2.692


My Raspberry Pi 2 model B+ with Hifiberry digiplus DAC was working ok with last version of Volumio.

First I upgraded to this version via web UI.

Then noticed volume control was not working (very quiet and only a tiny difference in level a full volume).

Tested a few things including changing volume in alsa-mixer via SSH.

Decided to try a fresh install of Volumio latest version.

Now, it fails to boot. After starting, I have ping only - no http, so ssh.

What is the procedure to debug in this circumstance?

So far I’v tried mounting the /volumio/volumio_current.sqsh file read-only on my ubuntu machine, with the intention of sifting through the logs I may find there(?) - but the file system looks untouched - no logs yet created:

~/volumio/squashfs$ tail var/log/dmesg 
(Nothing has been logged yet.)

Any help much appreciated!

Hi again

Problem solved by manually expanding the data partition on the newly flashed 8GB SD card before booting from it as per instructions here.

I guessed correctly(?) that that operation could be taking ‘forever’ (more than overnight/8 hours!) on my under-powered Pi 2.

I wonder if there needs to be a minimum hardware requirements list now that this auto-expansion is a feature?